solution Of 1069. The Black Hole of Numbers (20)

48 篇文章 0 订阅

1069. The Black Hole of Numbers (20)

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 – the “black hole” of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we’ll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
… …

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0, 10000).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation “N - N = 0000”. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:
6767
Sample Output 1:
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Sample Input 2:
2222
Sample Output 2:
2222 - 2222 = 0000


结题思路 :
题意要求我们在输出4位数的“黑洞”数字之前,输出求差的过程。
要求1:直接输入“黑洞数”值6174,我们仍然需要进行一步的输出;
要求2:当两个数值的差为6174时停止计算。

程序步骤:
第一步、对于输入数据进行字符化;
第二步、字符串内排序后求差。

具体程序(AC)如下:

#include<iostream>
#include<string>
#include<cstring>
#include<cstdlib>
#include<cmath> 
#include<sstream>
#include<algorithm>
using namespace std;
int cmp(char a,char b)
{
    return a>b;
}
string opDiff(string a)
{
     int startA,startB;
     char tmpA[5];
     char tmpB[5];
     strcpy(tmpA,a.c_str());
     sort(tmpA,tmpA+4,cmp);
     for(int i=0;i<4;++i)
         tmpB[i]=tmpA[3-i];
     tmpB[4]=0;
     cout<<tmpA<<" - "<<tmpB<<" = " ;
    for(int i=3;i>=0;--i)
    {
       if(tmpA[i]>=tmpB[i])
          tmpA[i]=tmpA[i]-tmpB[i]+'0';
       else
       {
          tmpA[i]=tmpA[i]+10;
          tmpA[i-1]=tmpA[i-1]-1; 
          tmpA[i]=tmpA[i]-tmpB[i]+'0';
       }
    }
    cout<<tmpA<<endl;
    a=tmpA;
    return a;
}
bool reversedEqual(char* tmp)
{
    int len=strlen(tmp);
    for(int i=0;i<len/2;++i)
        if(tmp[i]!=tmp[len-1-i])
            return false;
    return true;
}
int main()
{
    int value;
    cin>>value;
    char value2Str[5];
    sprintf(value2Str,"%04d",value);
    if(reversedEqual(value2Str))
      cout<<value2Str<<" - "<<value2Str<<" = 0000"<<endl;
    else
    {
        string sF(value2Str);
        if(sF=="6174")
        {
            cout<<"7641 - 1467 = 6174"<<endl;
            return 0;
        }
        while(sF!="6174")
            sF=opDiff(sF);
    }
    return 0;   
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值