PATA 1107 Social Clusters(30 分)解题报告

1107 Social Clusters(30 分)

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

K​i​​: h​i​​[1] h​i​​[2] ... h​i​​[K​i​​]

where K​i​​ (>0) is the number of hobbies, and h​i​​[j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4

Sample Output:

3
4 3 1

作者: CHEN, Yue

单位: 浙江大学

时间限制: 1200 ms

内存限制: 64 MB

代码长度限制: 16 KB

 

题目大意:每个人都有爱好,于是我们可以根据爱好来确定社交圈,当两个人有任意一个相同的爱好时,他们就进入同一个社交圈,以样例为例,1号喜欢2、7、10,2号喜欢4,3号喜欢5、3号喜欢5、3

  • 4号喜欢4,所以和2是一个社交圈
  • 5喜欢3,所以和3是一个社交圈
  • 6喜欢4,和2是一个社交圈
  • 7喜欢6、8、1、5,和3号有共同爱好5,所以和3号有同一个社交圈
  • 8喜欢4,和2是一个社交圈

于是我们可以得到一共有三个社交圈,2468组成一个,357组成一个,1自己一个人一个

解题思路:本题是典型的并查集问题,我们记录每个爱好的第一次出现,当出现一个活动的第一个爱好者时,我们把它记录进course[h]=i代表第i个人喜好h,此后凡是出现的爱好h,都会和这个人属于同一个社交网络,所以我们把他们合并,记录在father,至于形成了几个社交网络,就要看有几个集合,于是我们用isRoot每个集合有多少人,findFather(i)可以找到一个集合根点,所以isRoot数组中不等于0的元素个数,就代表了集合数。

 

AC代码:

#include<iostream>
#include<cstdio>
#include<string>
#include<algorithm>
#include<vector>
#include<set>
using namespace std;
int n;
const int maxn=1010;
int father[maxn];
int isRoot[maxn]={0};
int course[maxn]={0};
int findFather(int x);
void Union(int a,int b);
void init();
bool cmp(int a,int b);
int main()
{
	scanf("%d",&n);
	init();
	int h;
	int k;
	for(int i=1;i<=n;i++)
	{
		scanf("%d:",&k);
		for(int j=0;j<k;j++)
		{
			scanf("%d",&h);//输入第i个人的爱好h 
			if(course[h]==0)//如果活动h第一次有人喜欢 
				course[h]=i;
			Union(i,findFather(course[h]));
			//合并到father,father代表了每个人的社交网络,可以不断回溯到根节点
			//根节点相同的人属于一个网络 
		}
	}
	for(int i=1;i<=n;i++)
		isRoot[findFather(i)]++;//计算每个集合有多少人
	int ans=0;//集合数目 
	for(int i=1;i<=n;i++)
		if(isRoot[i]!=0)
			ans++;
	printf("%d\n",ans);
	sort(isRoot+1,isRoot+n+1,cmp);
	for(int i=1;i<=ans;i++)
	{
		printf("%d",isRoot[i]);
		if(i<ans)
			printf(" ");
	}
	return 0;
}

int findFather(int x)
{
	while(x!=father[x])
		x=father[x];
	return x;
}

void Union(int a,int b)
{
	int faA=findFather(a);
	int faB=findFather(b);
	if(faA!=faB)
		father[faA]=faB;
}

void init()
{
	for(int i=1;i<=n;i++)
	{
		father[i]=i;
		isRoot[i]=false;
	}
}

bool cmp(int a,int b)
{
	return a>b;
}
//当出现一个活动的第一个爱好者时,我们把它记录进course[h]=i
//代表第i个人喜好h,此后凡是出现的爱好h,都会和这个人属于同一个社交网络
//所以我们把他们合并,记录在father
//至于形成了几个社交网络,就要看有几个集合
//于是我们用isRoot每个集合有多少人,findFather(i)可以找到一个集合根节点
//所以isRoot数组中不等于0的元素个数,就代表了集合数 

 

  • 2
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值