Solution of 1144 The Missing Number (20)

48 篇文章 0 订阅

1144 The Missing Number (20)

Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<= 10^5^). Then N integers are given in the next line, separated by spaces. All the numbers are in the range of int.

Output Specification:

Print in a line the smallest positive integer that is missing from the input list.

Sample Input:
10
5 -25 9 6 1 3 4 2 5 17
Sample Output:
7


结题思路 :
题意要求在已知的正整数序列中发现这个序列中缺失的第一个正整数。由于正整数的无限性,这个缺失的数必然存在。

程序步骤:
第一步、只对正整数进行保存。
第二步、对序列进行排序。
第三步、从1开始对数列进行检查;如果没有发现,输出最后一个数+1。


具体程序(AC)如下:

#include <iostream>
#include <algorithm>
using namespace std;
int main()
{
    int vec[100005];
    int n;
    cin >> n;
    int value;
    int cur = 0;
    while(n--)
    {
        cin >> value;
        if(value > 0)
            vec[cur++] = value;
    }
    sort(vec, vec + cur);
    if(vec[0] != 1)
        cout<<1<<endl;
    else
    {
      int i = 1;
      for(; i < cur; ++i)
      {
          if(vec[i - 1] + 1 < vec[i])
          {
              cout<<vec[i - 1] + 1<<endl;
              break;
          }
      }
      if(cur == i)
        cout<<vec[cur - 1] + 1<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值