poj 3050 Hopscotch(暴力dfs)

问题描述

The cows play the child's game of hopscotch in a non-traditional way. Instead of a linear set of numbered boxes into which to hop, the cows create a 5x5 rectilinear grid of digits parallel to the x and y axes.

They then adroitly hop onto any digit in the grid and hop forward, backward, right, or left (never diagonally) to another digit in the grid. They hop again (same rules) to a digit (potentially a digit already visited).

With a total of five intra-grid hops, their hops create a six-digit integer (which might have leading zeroes like 000201).

Determine the count of the number of distinct integers that can be created in this manner.

输入

* Lines 1..5: The grid, five integers per line

输出

* Line 1: The number of distinct integers that can be constructed

样例输入

1 1 1 1 1
1 1 1 1 1
1 1 1 1 1
1 1 1 2 1
1 1 1 1 1

样例输出

15
开始看成了走5步结果WA了一发。。。
暴力dfs,直接一个一个的枚举,然后放入集合se里面,自动去重。最后再统计下se里面元素的个数即可。

代码如下:
#include <iostream>
#include <cstdio>
#include <set>
using namespace std;

int ma[6][6];
int num[10];
set<int> se;

int dx[]={0,0,1,-1};
int dy[]={1,-1,0,0};

void dfs(int x,int y,int deep)
{
    if(x>5||y>5||x<=0||y<=0)
        return ;
    if(deep==6)
    {
        int k=0;
        for(int i=0;i<deep;i++)
        {
            k=k*10+num[i];
        }
        se.insert(k);
        return ;
    }
    num[deep]=ma[x][y];
    for(int i=0;i<4;i++)
    {
        dfs(x+dx[i],y+dy[i],deep+1);
    }
}

int main()
{
    for(int i=1;i<=5;i++)
        for(int j=1;j<=5;j++)
        scanf("%d",&ma[i][j]);

    for(int i=1;i<=5;i++)
        for(int j=1;j<=5;j++)
        dfs(i,j,0);
        printf("%d\n",se.size());
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值