PAT 1001. A+B Format (20) c++版

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input
-1000000 9
Sample Output

-999,991


题目的意思:给出两个数(-1000000到1000000之间),求它们的和,并按照隔3个输出一个逗号的形式输出。


思路:根据题目意思求出两个数的和,flag来标记正负,将数从个位往前按位转换为char类型的数组,并且每隔三位加入一个逗号。


注意:数字的位数正好是3的整数倍时,第一位上会多出一个逗号。

#include <bits/stdc++.h>
using namespace std;


int main() {
	int a, b;
	cin >> a >> b;
	int c = a + b;
	char num[15];
	int index = 0, time = 0;
	int flag = 1;
	if (c < 0) {		//如果和是负数,flag记录下,并将它取反
		flag = 0;
		c = -c;
	} else if (c == 0) {		//和为0的情况,直接输出并返回
		cout << "0" << endl;
		return 0;
	}
	while (c > 0) {
		//index表示要插入的char类型数组的位置
		num[index++] = '0' + (char)(c % 10);
		//time用来记录数字的个数
		time++;
		c /= 10;
		//每隔3个数字就加入一个逗号
		if (time % 3 == 0) num[index++] = ',';
	}
	//3个数字加1个逗号,一共4位,index如果是4的整数倍,说明第一位上多了一个逗号
	if (index % 4 == 0) index--;
	if (!flag) cout << '-';
	for (int i = index - 1; i >= 0; i--)
		cout << num[i];
	cout << endl;
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值