Matrix

【题目描述】
Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).
We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using “not” operation (if it is a ‘0’ then change it into ‘1’ otherwise change it into ‘0’). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.
1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).
2. Q x y (1 <= x, y <= n) querys A[x, y].
【输入格式】
The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.
The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format “Q x y” or “C x1 y1 x2 y2”, which has been described above.
【输出格式】
For each querying output one line, which has an integer representing A[x, y].
There is a blank line between every two continuous test cases.
【样例输入】

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

【样例输出】

1
0
0
1

【分析】
二维差分+树状数组

#include<cstdio>
#include<cstring>
using namespace std;
const int Max=1010;
int bit[Max][Max]={0},n;
int lowbit(int x){return x&(-x);}
void Add(int x,int y,int z){
    for(int i=x;i>0;i-=lowbit(i))
        for(int j=y;j>0;j-=lowbit(j))
            bit[i][j]=(bit[i][j]+z+2&1);
}
int Query(int x,int y){
    int sum=0;
    for(int i=x;i<=n;i+=lowbit(i))
        for(int j=y;j<=n;j+=lowbit(j))
            sum+=bit[i][j];
    return sum&1;
}
int main(){
    int t,q,xx1,xx2,yy1,yy2;
    char str[10];
    scanf("%d",&t);
    while(t--){
        scanf("%d %d",&n,&q);
        memset(bit,0,sizeof(bit));
        while(q--){
            scanf("%s",str);
            if(str[0]=='C'){
                scanf("%d %d %d %d",&xx1,&yy1,&xx2,&yy2);
                Add(xx2,yy2,1),Add(xx1-1,yy2,-1),Add(xx2,yy1-1,-1),Add(xx1-1,yy1-1,1);
            }
            else{
                scanf("%d %d",&xx1,&yy1);
                printf("%d\n",Query(xx1,yy1));
            }
        }
        printf("\n");
    }
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值