next_permutation的函数声明:
#include <algorithm>
bool next_permutation( iterator start, iterator end );
The next_permutation() function attempts to transform the given range of elements [start,end) into the next lexicographically greater permutation of elements. If it succeeds, it returns true, otherwise, it returns false.
例题:Description
我们知道,正整数1~n的排列方案数为排列数A(n,n) = n!
请按字典序输出1~n的所有排列方式
Input
多组数据
每组数据有一行一个整数n(0<n<10)
请处理到文件末尾
Output
按字典序输出1~n的所有排列方案,一行一个方案
Sample Input
3
Sample Output
123
132
213
231
312
321
HINT
字典序的含义可以从样例中猜出...
AC代码:
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
int a[12];
int p=0;
int main()
{
int i,j,k,l,s,m,n;
while(~scanf("%d",&n))
{
memset(a,0,sizeof(a));
p=0;
for(i=0;i<n;i++)
{
a[i]=i+1;
}
do{
for(j=0;j<n;j++)
{
printf("%d",a[j]);
}
printf("\n");
}while (next_permutation(a,a+n));
}
return 0;
}
理解一下这个库函数就知道了。