next_permutation(求全排列的库函数)

next_permutation的函数声明:

#include <algorithm>
bool next_permutation( iterator start, iterator end );

The next_permutation() function attempts to transform the given range of elements [start,end) into the next lexicographically greater permutation of elements. If it succeeds, it returns true, otherwise, it returns false.
例题:Description

我们知道,正整数1~n的排列方案数为排列数A(n,n) = n!
请按字典序输出1~n的所有排列方式
Input
多组数据
每组数据有一行一个整数n(0<n<10)
请处理到文件末尾
Output
按字典序输出1~n的所有排列方案,一行一个方案
Sample Input
3
Sample Output
123
132
213
231
312
321
HINT
字典序的含义可以从样例中猜出...

AC代码:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
int a[12];
int p=0;
int main()
{
    int i,j,k,l,s,m,n;
    while(~scanf("%d",&n))
    {
        memset(a,0,sizeof(a));
        p=0;
        for(i=0;i<n;i++)
        {
            a[i]=i+1;
        }


        do{
            for(j=0;j<n;j++)
            {
                printf("%d",a[j]);
            }
            printf("\n");
        }while (next_permutation(a,a+n));
    }
    return 0;
}

理解一下这个库函数就知道了。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值