2016ACM暑假集训 - 4 Values whose Sum is 0

Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 2  28 ) that belong respectively to A, B, C and D .

Output

For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

Sample Output

5

Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).

解题思路:将4个数列分成两组,A和B求和,C和D求和,并分别存入两个数组,在通过二分法在另一个数组中查找相反数即可。


代码:

#include <cstdio>
#include <algorithm>
using namespace std;
long long a[4005];
long long b[4005];
long long c[4005];
long long d[4005];

long long sum1[4005*4005];
long long sum2[4005*4005];

bool bs(int i, int start, int end)
{
	int mid = (start+end) / 2;
	while(start <= end)
	{
		if(sum2[mid] + sum1[i] == 0)
		{
			return true;
		}
		else if(sum2[mid] + sum1[i] > 0)
		{
			end = mid - 1;
		}
		else
		{
			start = mid + 1;
		}
		mid = (start+end) / 2;
	}
	return false;
}
int main()
{
	int n;
	while(scanf("%d", &n) != EOF)
	{
		long long result = 0;
		for(int i = 0; i < n; i++)
		{
			scanf("%lld%lld%lld%lld", &a[i], &b[i], &c[i], &d[i]);
		}
		int k1 = 0;
		int k2 = 0;
		for(int i = 0; i < n; i++)
		{
			for(int j = 0; j < n; j++)
			{
				sum1[k1] = a[i] + b[j];
				k1++;
			}
		}
		sort(sum1, sum1+k1);
		for(int i = 0; i < n; i++)
		{
			for(int j = 0; j < n; j++)
			{
//				sum2[k2] = c[i] + d[j];
//				k2++;
				result += upper_bound(sum1, sum1+k1,-c[i]-d[j]) - lower_bound(sum1, sum1+k1,-c[i]-d[j]);
			}
		}
//		sort(sum2, sum2+k2);
		
//		for(int i = 0; i < k1; i++)
//		{
//			
//			if(bs(i, 0, k2))
//			{
//				result++;
//			}
//		}
		printf("%lld\n", result);
	}
	return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值