poj2299

转化为计算逆序对的问题

,用到了归并排序的思想

Ultra-QuickSort
Time Limit: 7000MS Memory Limit: 65536K
Total Submissions: 54245 Accepted: 19926

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 
9 1 0 5 4 ,

Ultra-QuickSort produces the output 
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<malloc.h>
#include<math.h>
long long num[500005];
long temp[500005];
long long ans=0;
int n;

void merge(int low,int mid,int high){
    int i=low,j=mid+1,k=low;
    while(i<=mid&&j<=high){
        if(num[i]<=num[j]){
            temp[k]=num[i];
            k++;
            i++;
        }
        else{
            ans+=j-k;//统计逆序
            temp[k]=num[j];
            k++;
            j++;
        }
    }
    while(i<=mid){
        temp[k]=num[i];
        k++;
        i++;
    }
    while(j<=high){
        temp[k]=num[j];
        k++;
        j++;
    }
    for(i=low;i<=high;i++){
        num[i]=temp[i];
    }
}
void mergesort(int a,int b){
    if(a<b){
        int mid=(a+b)/2;
        mergesort(a,mid);
        mergesort(mid+1,b);
        merge(a,mid,b);
    }
}
int main(){
    while(~scanf("%d",&n)&&n){
        ans=0;
        int i;
        for(i=0;i<n;i++){
            scanf("%lld",&num[i]);
        }
        mergesort(0,n-1);
        printf("%lld\n",ans);
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值