HDU 2586 How far away?

There are n houses in the village and some bidirectional roads connecting them. Every day peole always like to ask like this "How far is it if I want to go from house A to house B"? Usually it hard to answer. But luckily int this village the answer is always unique, since the roads are built in the way that there is a unique simple path("simple" means you can't visit a place twice) between every two houses. Yout task is to answer all these curious people.

Input

First line is a single integer T(T<=10), indicating the number of test cases. 
  For each test case,in the first line there are two numbers n(2<=n<=40000) and m (1<=m<=200),the number of houses and the number of queries. The following n-1 lines each consisting three numbers i,j,k, separated bu a single space, meaning that there is a road connecting house i and house j,with length k(0<k<=40000).The houses are labeled from 1 to n. 
  Next m lines each has distinct integers i and j, you areato answer the distance between house i and house j.

Output

For each test case,output m lines. Each line represents the answer of the query. Output a bland line after each test case.

Sample Input

2
3 2
1 2 10
3 1 15
1 2
2 3

2 2
1 2 100
1 2
2 1

Sample Output

10
25
100
100

dfs暴力求解

#include<bits/stdc++.h>
using namespace std;
int n, m;
int e;
int flag = 0;
struct node{
    int to, cost;
};
vector<struct node>mp[40010];
int vis[40010];

void dfs(int s, int ans){
    if(flag == 1)return;
    if(vis[s])return;
    if(s == e){
        printf("%d\n", ans);
        flag = 1;
        return;
    }
    if(mp[s].empty())return;
    int len = mp[s].size();
    vis[s] = 1;
    for(int i = 0; i <= len - 1; i++){
        dfs(mp[s][i].to, ans + mp[s][i].cost);
    }
    vis[s] = 0;
}

int main(){
    int t;
    cin >> t;
    int s;
    while(t--){
        cin >> n >> m;
        for(int i = 1; i <= n - 1; i++){
            int x, y, w;
            cin >> x >> y >> w;
            node t;
            t.to = y;
            t.cost = w;
            mp[x].push_back(t);
            t.to = x;
            t.cost = w;
            mp[y].push_back(t);
        }
        for(int i = 0; i <= m - 1; i++){
            cin >> s >> e;
            memset(vis, 0, sizeof(vis));
            flag = 0;
            dfs(s, 0);
        }
        for(int i = 0; i < n; i++){
            mp[i].clear();
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值