2016HDU多校联赛-HDU-5734-Acperience(模拟分数运算)

Acperience

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 371 Accepted Submission(s): 191

Problem Description
Deep neural networks (DNN) have shown significant improvements in several application domains including computer vision and speech recognition. In computer vision, a particular type of DNN, known as Convolutional Neural Networks (CNN), have demonstrated state-of-the-art results in object recognition and detection.

Convolutional neural networks show reliable results on object recognition and detection that are useful in real world applications. Concurrent to the recent progress in recognition, interesting advancements have been happening in virtual reality (VR by Oculus), augmented reality (AR by HoloLens), and smart wearable devices. Putting these two pieces together, we argue that it is the right time to equip smart portable devices with the power of state-of-the-art recognition systems. However, CNN-based recognition systems need large amounts of memory and computational power. While they perform well on expensive, GPU-based machines, they are often unsuitable for smaller devices like cell phones and embedded electronics.

In order to simplify the networks, Professor Zhang tries to introduce simple, efficient, and accurate approximations to CNNs by binarizing the weights. Professor Zhang needs your help.

More specifically, you are given a weighted vector W=(w1,w2,…,wn). Professor Zhang would like to find a binary vector B=(b1,b2,…,bn) (bi∈{+1,−1}) and a scaling factor α≥0 in such a manner that ∥W−αB∥2 is minimum.

Note that ∥⋅∥ denotes the Euclidean norm (i.e. ∥X∥=x21+⋯+x2n−−−−−−−−−−−√, where X=(x1,x2,…,xn)).

Input
There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first line contains an integers n (1≤n≤100000) – the length of the vector. The next line contains n integers: w1,w2,…,wn (−10000≤wi≤10000).

Output
For each test case, output the minimum value of ∥W−αB∥2 as an irreducible fraction “p/q” where p, q are integers, q>0.

Sample Input
3
4
1 2 3 4
4
2 2 2 2
5
5 6 2 3 4

Sample Output
5/1
0/1
10/1

小心爆longlong 和除零运算
队友的代码

#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<string.h>
#include<string>
#include<math.h>
#include<queue>
#include<vector>
#include<map>
#include<set>


using namespace std;
typedef long long int LL;
const int INF=2e9+1e8;
const int MAXSIZE=1e6;

LL num[MAXSIZE];
LL gcd(LL a,LL b)
{
    a=abs(a),b=abs(b);
    return __gcd(a,b);
}


struct ZP
{
    LL up,down;
};
ZP add(ZP a,ZP b)
{
    ZP ans;
    LL gc;
    ans.down=a.down*b.down;
    ans.up=a.up*b.down+b.up*a.down;
    gc=gcd(ans.up,ans.down);
    ans.up/=gc,ans.down/=gc;
    return ans;
}
ZP jian(ZP a,ZP b)
{
    ZP ans;
    LL gc;
    ans.down=a.down*b.down;
    ans.up=a.up*b.down-b.up*a.down;
    gc=gcd(ans.up,ans.down);
    ans.up/=gc,ans.down/=gc;
    return ans;
}
ZP pow2(ZP a)
{
    ZP ans;
    ans.up=a.up*a.up;
    ans.down=a.down*a.down;
    return ans;
}
ZP sim(ZP a)
{
    ZP ans;
    LL gc=gcd(a.down,a.up);
    ans.up=a.up/gc;
    ans.down=a.down/gc;
    return ans;
}
void cout_(ZP a)
{
    printf("AC = %I64d/%I64d\n",a.up,a.down);
}
int main()
{
    LL ncase;
    cin>>ncase;
    while(ncase--)
    {
        LL n,sum=0ll,sum2=0ll;
        scanf("%I64d",&n);
        for(LL i=1; i<=n; i++)
        {
            scanf("%I64d",&num[i]);
            sum+=abs(num[i]);
            sum2+=num[i]*num[i];
        }
        LL up=n*sum2-sum*sum,down=n;
        LL gc=gcd(up,down);
        up/=gc,down/=gc;
        if(up==0) printf("0/1\n");
        else printf("%I64d/%I64d\n",up,down);


//        ZP ans,fen0,arv;
//        arv.up=sum,arv.down=n;
//        ans.up=0,ans.down=1;
//        fen0=ans;
//        sim(arv);
        cout_(arv);
        return 0;
//        for(LL i=1; i<=n; i++)
//        {
//            ZP tp;
//            tp.up=num[i],tp.down=1;
//            ans=add(ans,pow2(jian(arv,tp)));
//        }
//        if(ans.up==0) printf("0/1\n");
//        else printf("%I64d/%I64d\n",ans.up,ans.down);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值