hdu5734——Acperience(数学推导)

Problem Description
Deep neural networks (DNN) have shown significant improvements in several application domains including computer vision and speech recognition. In computer vision, a particular type of DNN, known as Convolutional Neural Networks (CNN), have demonstrated state-of-the-art results in object recognition and detection.

Convolutional neural networks show reliable results on object recognition and detection that are useful in real world applications. Concurrent to the recent progress in recognition, interesting advancements have been happening in virtual reality (VR by Oculus), augmented reality (AR by HoloLens), and smart wearable devices. Putting these two pieces together, we argue that it is the right time to equip smart portable devices with the power of state-of-the-art recognition systems. However, CNN-based recognition systems need large amounts of memory and computational power. While they perform well on expensive, GPU-based machines, they are often unsuitable for smaller devices like cell phones and embedded electronics.

In order to simplify the networks, Professor Zhang tries to introduce simple, efficient, and accurate approximations to CNNs by binarizing the weights. Professor Zhang needs your help.

More specifically, you are given a weighted vector . Professor Zhang would like to find a binary vector and a scaling factor in such a manner that is minimum.

Note that denotes the Euclidean norm (i.e. , where ).

Input
There are multiple test cases. The first line of input contains an integer , indicating the number of test cases. For each test case:

The first line contains an integers – the length of the vector. The next line contains integers: .

Output
For each test case, output the minimum value of as an irreducible fraction “/” where , are integers, .

Sample Input
3
4
1 2 3 4
4
2 2 2 2
5
5 6 2 3 4

Sample Output
5/1
0/1
10/1

题解报告写的很详细了

这里写图片描述

#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <map>
#include <cmath>
#include <algorithm>
#define INF 0x3f3f3f3f
#define MAXN 1010
#define mod 1000000007
using namespace std;
long long gcd(long long a,long long b)
{
    if(b==0)
        return a;
    else
        return gcd(b,a%b);
}
int main()
{
    int t,n;
    scanf("%d",&t);
    while(t--)
    {
        long long sum1=0,sum2=0,w;
        scanf("%d",&n);
        for(int i=1;i<=n;++i)
        {
            scanf("%I64d",&w);
            sum1+=abs(w);
            sum2+=(w*w);
        }
        long long a=n*sum2-(sum1*sum1);
        long long b=n;
        long long c=gcd(a,b);
        long long aa=a/c,bb=b/c;
        printf("%I64d/%I64d\n",aa,bb);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值