HDU-2577-How to Type(DP)

How to Type

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6239 Accepted Submission(s): 2821

Problem Description
Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.

Input
The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.

Output
For each test case, you must output the smallest times of typing the key to finish typing this string.

Sample Input
3
Pirates
HDUacm
HDUACM

Sample Output
8
8
8

Hint

The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8.
The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8
The string “HDUACM”, can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8

题意:给出字符串,初始时Caps大写灯是关着的,输入时可以打开Caps或者SHift+字符,那么问题来了,把他们敲出来需要几次?

状态转移描述:

对于小写字母,
如果Caps大写灯是关着的,那直接敲一次就好
如果Caps是开的,那么可以选择Shift+字母,也可以选择关掉Caps再敲字母,需要两次操作

对于大写字母
如果Caps大写灯是关着的,可以选择Shift+字母或者打开Caps再敲字符,需要两次操作
如果Caps是关着的,直接敲一次就好

代码

#include <stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
const int maxn=105;
int DP_bright[maxn];//写完前i个字母时cap灯亮需要DP_bright[i]次操作
int DP_destroy[maxn];//写完前i个字母时cap灯灭需要DP_destroy[i]次操作
char str[maxn];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%s",str+1);
        int len=strlen(str+1);
        DP_bright[0]=2;//初始时灯是灭的
        DP_destroy[0]=0;
        for(int i=1;i<=len;i++)
        {
            if(str[i]>='a'&&str[i]<='z')
            {
                DP_bright[i]=min(DP_bright[i-1]+2,DP_destroy[i-1]+2);
                DP_destroy[i]=min(DP_bright[i-1]+2,DP_destroy[i-1]+1);
            }
            else if(str[i]>='A'&&str[i]<='Z')
            {
                DP_bright[i]=min(DP_bright[i-1]+1,DP_destroy[i-1]+2);
                DP_destroy[i]=min(DP_bright[i-1]+2,DP_destroy[i-1]+2);
            }
        }
        printf("%d\n",min(DP_bright[len]+1,DP_destroy[len]));//最后使灯亮的灭灯还需要操作一次
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值