POJ-2342-Anniversary party(树形DP)

Anniversary party
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7356 Accepted: 4228
Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests’ conviviality ratings.
Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0
Output

Output should contain the maximal sum of guests’ ratings.
Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0
Sample Output

5

树形DP入门~

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<math.h>
#include<vector>
using namespace std;
const int maxn=6005;
int DP[maxn][2];
int Father[maxn];
int vis[maxn];
int N;
void DFS(int point)
{
    vis[point]=1;
    for(int i=1; i<=N; i++)
    {
        if(vis[i]==0&&Father[i]==point)
        {
            DFS(i);
            DP[point][1]+=DP[i][0];
            DP[point][0]+=max(DP[i][1],DP[i][0]);
        }
    }
}
int main()
{
    while(scanf("%d",&N)!=EOF)
    {
        memset(DP,0,sizeof(DP));
        memset(Father,0,sizeof(Father));
        memset(vis,0,sizeof(vis));
        for(int i=1; i<=N; i++)
            scanf("%d",&DP[i][1]);
        int u,v;
        while(scanf("%d%d",&u,&v),u||v)
            Father[u]=v;
        int root=1;//更改获取根节点的方式
        while(Father[root])
            root=Father[root];
        DFS(root);
        printf("%d\n",max(DP[root][0],DP[root][1]));
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值