HDU 1242 Rescue(BFS+【优先队列】)

61 篇文章 0 订阅
9 篇文章 0 订阅

Problem Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel’s friends want to save Angel. Their task is: approach Angel. We assume that “approach Angel” is to get to the position where Angel stays. When there’s a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)

Input
First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. “.” stands for road, “a” stands for Angel, and “r” stands for each of Angel’s friend.

Process to the end of the file.

Output
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing “Poor ANGEL has to stay in the prison all his life.”

Sample Input
7 8

#.#####.
#.a#..r.
#..#x...
..#..#.#
#...##..
.#......
........

Sample Output
13


第一次使用优先队列做搜索题,心里还是有点陌生的,但我相信以后一定会慢慢熟悉起来的。
为什么使用优先队列呢?因为本道题中行走时如果遇到守卫的话需要花费1个单位的时间来杀死守卫。所以用优先队列处理最短时间较好。
下面是AC代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<queue>
using namespace std;

struct node
{
    int x,y,step;
    friend bool operator<(node t1,node t2)
    {
        return t1.step>t2.step;
    }
};
int dir[4][2]= {{0,1},{0,-1},{1,0},{-1,0}};
char a[205][205];
int book[205][205];
int sx,sy,ex,ey,n,m;;

int bfs(int sx,int sy,int ex,int ey)
{
    node fr,ne;
    memset(book,0,sizeof(book));
    priority_queue<node>q;
    while(!q.empty())
    {
        q.pop();
    }
    fr.x=sx,fr.y=sy,fr.step=0;
    q.push(fr);
    book[sx][sy]=1;
    while(!q.empty())
    {
        fr=q.top();
        q.pop();
        if(fr.x==ex&&fr.y==ey)
        {
            return fr.step;
        }
        for(int i=0;i<4;i++)
        {
            ne.x=fr.x+dir[i][0];
            ne.y=fr.y+dir[i][1];
            ne.step=fr.step+1;
            if(a[ne.x][ne.y]!='#'&&ne.x>=0&&ne.x<n&&ne.y>=0&&ne.y<m&&!book[ne.x][ne.y])
            {
                if(a[ne.x][ne.y]=='x')
                {
                    ne.step++;
                    book[ne.x][ne.y]=1;
                    q.push(ne);
                }
                else
                {
                    book[ne.x][ne.y]=1;
                    q.push(ne);
                }
            }
        }
    }
    return -1;
}

int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=0; i<n; i++)
        {
            scanf("%s",&a[i]);
            for(int j=0; j<m; j++)
            {
                if(a[i][j]=='a')
                {
                    ex=i;
                    ey=j;
                }
                if(a[i][j]=='r')
                {
                    sx=i,sy=j;
                }
            }
        }
        int re=bfs(sx,sy,ex,ey);
        if(re!=-1)
        printf("%d\n",re);
        else{
            printf("Poor ANGEL has to stay in the prison all his life.\n");
        }
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值