POJ 1797 Heavy Transportation(最小生成树或最短路)

30 篇文章 1 订阅
24 篇文章 0 订阅

Description

Background
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight.
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.

Problem
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo’s place) to crossing n (the customer’s place). You may assume that there is at least one path. All streets can be travelled in both directions.
Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.
Output

The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.
Sample Input

1
3 3
1 2 3
1 3 4
2 3 5
Sample Output

Scenario #1:
4
题目的意思是让你求从1到n的最短路的最小边的最大值,所以Kruskal就可以水过了,当然也可以用Dijkstra过,其实很简单。有兴趣的可以拿最短路做下,在这里先贴上一个代码,,回头会把最短路的代码补上。
下面是Kruskal的代码:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;

struct node
{
    int x,y,cost;
}a[1000005];
int pre[1005];
int fin(int x)
{
    if(x==pre[x])
    {
        return x;
    }
    else
    {
        return pre[x]=fin(pre[x]);
    }
}

void join(int x,int y)
{
    int t1=fin(x);
    int t2=fin(y);
    if(t1!=t2)
    {
        pre[t1]=t2;
    }
}

bool cmp(node p,node q)
{
    return p.cost>q.cost;
}

int main()
{
    int t,n,m,iCase=0;
    cin>>t;
    while(t--)
    {
        iCase++;
        cin>>n>>m;
        for(int i=1;i<=n;i++)
        {
            pre[i]=i;
        }
        for(int i=0;i<m;i++)
        {
            cin>>a[i].x>>a[i].y>>a[i].cost;
        }
        sort(a,a+m,cmp);
        int sum=0;
        for(int i=0;i<m;i++)
        {
            if(fin(1)==fin(n))
            {
                break;
            }
            if(fin(a[i].x)!=fin(a[i].y))
            {
                join(a[i].x,a[i].y);
                sum=a[i].cost;
            }
        }
        cout<<"Scenario #"<<iCase<<":"<<endl;
        cout<<sum<<endl<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值