HDU 5655 CA Loves Stick(思维题目)【bestcoder】

109 篇文章 0 订阅
16 篇文章 0 订阅

CA Loves Stick

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 2130    Accepted Submission(s): 615


Problem Description
CA loves to play with sticks.
One day he receives four pieces of sticks, he wants to know these sticks can spell a quadrilateral.
(What is quadrilateral? Click here: https://en.wikipedia.org/wiki/Quadrilateral)
 

Input
First line contains  T  denoting the number of testcases.
T  testcases follow. Each testcase contains four integers  a,b,c,d  in a line, denoting the length of sticks.
1T1000, 0a,b,c,d2631
 

Output
For each testcase, if these sticks can spell a quadrilateral, output "Yes"; otherwise, output "No" (without the quotation marks).
 

Sample Input
  
  
2 1 1 1 1 1 1 9 2
 

Sample Output
  
  
Yes No
 
本题的题意就是给你四根木棒,然后问你能不能组成四边形,四边形的定义上面已经给出。
很明显需要满足最小的三条边之和大于第四条边,而且最小的边不能为0 。
直接加的话会爆long long ,所以我们需要转换一下思路,就是最小的边大于最长的边减去另外两条边的长度。
下面是AC代码:
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define ll long long

ll a[4];

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%I64d %I64d %I64d %I64d",&a[0],&a[1],&a[2],&a[3]);
        sort(a,a+4);
        if(a[0]==0)
        {
            printf("No\n");
            continue;
        }
        if(a[0]>a[3]-a[2]-a[1])
        {
            printf("Yes\n");
        }
        else
        {
            printf("No\n");
        }
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值