HDU58739(Football Games)思维



Football Games

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 57    Accepted Submission(s): 19


Problem Description
A mysterious country will hold a football world championships---Abnormal Cup, attracting football teams and fans from all around the world. This country is so mysterious that none of the information of the games will be open to the public till the end of all the matches. And finally only the score of each team will be announced.
  
  At the first phase of the championships, teams are divided into
M groups using the single round robin rule where one and only one game will be played between each pair of teams within each group. The winner of a game scores 2 points, the loser scores 0, when the game is tied both score 1 point. The schedule of these games are unknown, only the scores of each team in each group are available.
  
  When those games finished, some insider revealed that there were some false scores in some groups. This has aroused great concern among the pubic, so the the Association of Credit Management (ACM) asks you to judge which groups' scores must be false.
 

Input
Multiple test cases, process till end of the input.
  
  For each case, the first line contains a positive integers
M , which is the number of groups.
  The
i -th of the next M lines begins with a positive integer Bi representing the number of teams in the i -th group, followed by Bi nonnegative integers representing the score of each team in this group.


number of test cases <= 10
M<= 100
B[i]<= 20000
score of each team <= 20000
 

Output
For each test case, output M lines. Output ``F" (without quotes) if the scores in the i-th group must be false, output ``T" (without quotes) otherwise. See samples for detail.
 

Sample Input
  
  
2 3 0 5 1 2 1 1
 

Sample Output
  
  
F T
 

Source
题意:T组数据,M个球队,两个队之间有仅有一场比赛,赢者加2分,输不加分,平局各加一分。给出m个队的总得分,问是否属实。
题解:
一直Wa的,把T改成多组输入看看。假设我们将队伍编号为1-n,小号队总能打赢大号队,所以最后得分2*(n-1),2*(n-2)。。。0
将实际得分按从大到小排序,用假设的得分减去实际得分,sum记录,如果小于0,退出,输出F,否则,说明该球队输过或平局过,这样多出的分就可以加在其他队上,最后sum值应为为0
代码:
#include <bits/stdc++.h>
using namespace std;
int a[1000000];
int main()
{
    int t;
    while(~scanf("%d",&t))
    {
        while(t--)
        {
            int n;
            scanf("%d",&n);
            for(int i=1;i<=n;i++)
                scanf("%d",&a[i]);
                int flag=1;
                int sum=0;
                int he=2*(n-1);
                sort(a+1,a+1+n);
                reverse(a+1,a+1+n);
                for(int i=1;i<=n;i++)
                {
                    sum+=(he-a[i]);
                    if(sum<0)
                    {
                        flag=0;
                        break;
                    }
                    he-=2;
                }
                if(sum==0&&flag)
                    printf("T\n");
                else
                    printf("F\n");
        }
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值