Hdu 5873 Football Games 推理(XJBC

Football Games

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2082    Accepted Submission(s): 764


Problem Description
A mysterious country will hold a football world championships---Abnormal Cup, attracting football teams and fans from all around the world. This country is so mysterious that none of the information of the games will be open to the public till the end of all the matches. And finally only the score of each team will be announced. 
  
  At the first phase of the championships, teams are divided into  M  groups using the single round robin rule where one and only one game will be played between each pair of teams within each group. The winner of a game scores 2 points, the loser scores 0, when the game is tied both score 1 point. The schedule of these games are unknown, only the scores of each team in each group are available.
  
  When those games finished, some insider revealed that there were some false scores in some groups. This has aroused great concern among the pubic, so the the Association of Credit Management (ACM) asks you to judge which groups' scores must be false.
 

Input
Multiple test cases, process till end of the input.
  
  For each case, the first line contains a positive integers  M , which is the number of groups.
  The  i -th of the next  M  lines begins with a positive integer  Bi  representing the number of teams in the  i -th group, followed by  Bi  nonnegative integers representing the score of each team in this group.


number of test cases <= 10
M<= 100
B[i]<= 20000
score of each team <= 20000
 

Output
For each test case, output  M  lines. Output ``F" (without quotes) if the scores in the i-th group must be false, output ``T" (without quotes) otherwise. See samples for detail.
 

Sample Input
  
  
2 3 0 5 1 2 1 1
 

Sample Output
  
  
F T
 



给你n支足球队,打单循环小组赛,胜者2分,平局各1分,负者0分,判断最后的得分是否可能。


通过XJBC得到,把比分排序后,前i个队伍得分前缀和最多为2*(n-1)+2*(n-2)...+2*(n-i).

因为,前面的队伍赢得的分数最多时,后面的队伍全部败给前面的队伍,此时的最大总得分就是这么多。

比较坑的是多case。


感动啊,这么多天终于有一个猜出来的题目了


#include <cstdio>
#include <iostream>
#include <string.h>
#include <string> 
#include <map>
#include <queue>
#include <vector>
#include <set>
#include <algorithm>
#include <math.h>
#include <cmath>
#include <bitset>
#define mem0(a) memset(a,0,sizeof(a))
#define meminf(a) memset(a,0x3f,sizeof(a))
using namespace std;
typedef long long ll;
typedef long double ld;
const int maxn=20005,inf=0x3f3f3f3f;
const ll llinf=0x3f3f3f3f3f3f3f3f; 
const ld pi=acos(-1.0L);
int a[maxn],sum[maxn];

bool cmp(int a,int b) {
	return a>b;
}

int main() {
//	freopen("input.txt","r",stdin);
//	freopen("output.txt","w",stdout);
	int i,cas,n;
while(scanf("%d",&cas)!=EOF) {
	while (cas--) {
		scanf("%d",&n);
		int flag=1;
		for (i=1;i<=n;i++) {
			scanf("%d",&a[i]);
		}
		sort(a+1,a+n+1,cmp);
		int i=1;
		int u=0;
		sum[0]=0;
		for (i=1;i<=n;i++) {
			sum[i]=sum[i-1]+a[i];
			u+=2*(n-i);
			if (sum[i]>u) flag=0;
		}
		if (sum[n]!=n*(n-1)) flag=0;
		if (flag) printf("T\n"); else printf("F\n");
	} 
}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值