POJ 2955 Brackets [区间DP]【动态规划】

题目链接: http://poj.org/problem?id=2955
———————————.
Brackets
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6430 Accepted: 3443
Description

We give the following inductive definition of a “regular brackets” sequence:

the empty sequence is a regular brackets sequence,
if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
if a and b are regular brackets sequences, then ab is a regular brackets sequence.
no other sequence is a regular brackets sequence
For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ n, ai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end
Sample Output

6
6
4
0
6


题目大意:就是问你 整个区间内 不连续的能匹配上的括号的总数

解题思路:
区间DP
dp[i][j] = i~j 区间内能够匹配的括号的个数
很简单 详见代码吧

附本题代码
—————————————-.

//#include <bits/stdc++.h>
#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;
#define lalal puts("*****");

typedef long long LL;
const int MOD  = 1000000007;
const int maxn = 200010;

int dp[101][101];
char a[101];

int main()
{
    while(scanf("%s",a)!=EOF)
    {
        memset(dp,0,sizeof(dp));

        if(a[0]=='e')  break;
        int l = strlen(a);
        for(int len=1; len<l; len++) //区间的长度
            for(int i=0,j=len; j<l; i++,j++)   //不同的区间啊
            {
                if(a[i]=='('&&a[j]==')'||a[i]=='['&&a[j]==']')  //如果区间两边能够构成括号的匹配 就+2
                    dp[i][j]=dp[i+1][j-1]+2;
                for(int k=i; k<j; k++)                          //合并区间啊 维护最大值
                    dp[i][j]=max(dp[i][j],dp[i][k]+dp[k+1][j]);
            }

        printf("%d\n",dp[0][l-1]);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值