“玲珑杯”ACM比赛 Round #9 A -- Check-in Problem [因子个数]【数论】

题目连接:http://www.ifrog.cc/acm/problem/1084

———————————————————————————————————-.
A – Check-in Problem
Time Limit:5s Memory Limit:128MByte

Submissions:921 Solved:55

DESCRIPTION

A positive integer x is called p-bizarre number if the number of the divisors of x is p exactly.
Your task is testing whether the given positive integer n is a p-bizarre number or not.

INPUT

The first line contains a positive integer T, which represents there are T test cases.
The following is test cases. For each test case:
The only one line contains a positive integer n and an odd prime p.
1≤T≤10^5,1≤n≤10^18,2< p≤10^9

OUTPUT

For each test case, output in one line, print “YES” (without quote) if n is a p-bizarre number, print “NO” (without quote) otherwise.

SAMPLE INPUT

3
9 3
971528476274196481 7
150094635296999121 37

SAMPLE OUTPUT
YES
NO
YES
———————————————————————————————————-.
题目大意:
就是问你n的因子个数是不是p个

解题思路:
对于一个素数n的因子个数 我们可以对n做算术基本定理展开
n=pa11×pa22×pa33×...×parr

那么数的因子个数就是 ri=1(a1+1)×(a2+1)×(a3+1)×...×(an+1)

input里面又说
The only one line contains a positive integer n and an odd prime p.

那么对于p是素数的情况 只能说明n的质因子只有一种,

因为上述,所以我想到以对1e6(因为题目说p最小是3,n最大是10^18,所以1e6就够了)内的素数筛法取一遍,然后二分寻找答案即可注意会爆LL ,但是无论怎么控制溢出,最后代码写成了这样但是还是WA…心塞…

献上官方题解

注意到 p 是质数,只有当 n 是质数的 p1 次幂时, n 的约数才可能恰好有 p 个,所以判定一个正整数 n p奇异数,只需检验 p1n 是整数,且 p1n 是质数。预处理 109 以内的素数(共 3401 个),进行开根和判断素数即可,时间复杂度 O(nlnn)
事实上 p>3 的情况很少有解,直接预处理所有有解的情况即可,可以防止写出有问题的开根,而 p=3 的判断素数也可以用 Miller-Rabin 算法判定(需要 O(1) 的模乘法)。

改了2个小时的溢出,最后都没签到。。。。。。

献上标程一枚
———————————————————————————————————-.

#include <cmath>
#include <stdio.h>
#include <cassert>
#include <algorithm>
typedef long long LL;
const int maxn = 31623, maxm = 17, maxp = 61, maxt = 100001, maxv2 = (int)1e9;
const LL maxv = (LL)1e18;
int tot, pr[maxn], d[maxn], sz[maxm];
LL pp[maxm][maxn];
bool isprime(int x)
{
    if(x < 2)    return 0;
    if(x < maxn) return d[x] == x;
    for(int i = 0; i < tot && pr[i] * pr[i] <= x; ++i)
        if(x % pr[i] == 0)  return 0;
    return 1;
}
int main()
{
    for(int i = 2; i < maxn; ++i)
    {
        if(!d[i])
            pr[tot++] = d[i] = i;
        for(int j = 0, k; (k = i * pr[j]) < maxn; ++j)
        {
            d[k] = pr[j];
            if(d[i] == pr[j])break;
        }
    }

    for(int i = 2; i < maxm; ++i)
        for(int j = 0; j < tot; ++j)
        {
            int rem = pr[i] - 1;
            LL val = 1, lim = maxv / pr[j];
            for( ; rem && val <= lim; --rem, val *= pr[j]);
            if(rem)     break;
            pp[i][sz[i]++] = val;
        }

    int t;
    LL n, p;
    assert(scanf("%d", &t) == 1
    && 1 <= t && t < maxt);
    while(t--)
    {
        assert(scanf("%lld%lld", &n, &p) == 2
        && 1 <= n && n <= maxv
        && (p & 1) && p <= maxv2 && isprime(p));
        if(p >= maxp || d[p] != p)
        {
            puts("NO");
            continue;
        }
        if(p == 3)
        {
            LL val = (LL)sqrt(n);
            for( ; val * val > n; --val);
            for( ; (val + 1) * (val + 1) <= n; ++val);
            puts(val * val == n && isprime(val) ? "YES" : "NO");
            continue;
        }
        for(int i = 2; i < maxm; ++i)
            if(pr[i] == p)
            {
                puts(*std::lower_bound(pp[i], pp[i] + sz[i], n) == n ? "YES" : "NO");
                break;
            }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值