poj2299 Ultra-QuickSort


D - Ultra-QuickSort
Time Limit:7000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 
9 1 0 5 4 ,

Ultra-QuickSort produces the output 
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

原来是超快速排序,我说用快排怎么不对。他要的是冒泡排序的简单说就是逆序对,用归并就可以。

#include <iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;
int temp[500005];
int a[500005];
long long sum;
void  hebing(int *a,int first,int med,int last)
{
    int cur =0,i=first,j=med+1;
    while(i<=med&&j<=last)
    {
        if(a[i]<=a[j])
        {
            temp[cur++]=a[i++];
            continue;
        }
        else
        {
            sum+=med-i+1;
            temp[cur++]=a[j++];
        }
    }
    while(i<=med)temp[cur++]=a[i++];
    while(j<=last)temp[cur++]=a[j++];
    for(i=0; i<cur; i++)a[first++]=temp[i];
}
void gb(int *a,int first,int last)
{
    if(first==last)return;
    int med=(first+last)/2;
    gb(a,first,med);
    gb(a,med+1,last);
    hebing(a,first,med,last);
}
int main()
{

    int n;
    int i;
    while(~scanf("%d",&n))
    {
        if(!n)break;
        for(i = 0; i < n; ++i)scanf("%d",&a[i]);
         sum=0;
       gb(a,0,n-1);
       printf("%lld\n",sum);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值