poj3264(线段树) Balanced Lineup

C - Balanced Lineup
Time Limit:5000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers,  N and  Q
Lines 2..  N+1: Line  i+1 contains a single integer that is the height of cow  i
Lines  N+2..  NQ+1: Two integers  A and  B (1 ≤  A ≤  B ≤  N), representing the range of cows from  A to  B inclusive.

Output

Lines 1..  Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

这个题就是给你一个牛的序列,然后有Q次询问,每次问你这个区间中高度最高的和最低的差是多少,又是区间更新问题辣,很容易就想到用线段树了吧,直接仿照上面那个题葫芦画的瓢,这次就是想到每个结点用来记录最大值和最小值就够了,建完树就直接搜索就可以辣~,注意搜索函数加一个变量,来标记你是搜索的最大值还是最小值~

感觉自己多敲几次,理解思路线段树还是没有多难哒

#include <iostream>
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <queue>
#include <map>
#include <string>
#include <cstring>
#include <vector>
using namespace std;
const int MAXN=50000+5;
int n,m;
struct node
{
    int l,r;
    int MAX,MIN;
}tree[MAXN<<2];
void build(int i,int l,int r)
{
    tree[i].l=l;
    tree[i].r=r;
    if(l==r)
    {
        scanf("%d",&tree[i].MAX);
        tree[i].MIN=tree[i].MAX;
        return;
    }
    int mid=(l+r)>>1;
    build(i<<1,l,mid);
    build(i<<1|1,mid+1,r);
    tree[i].MAX=max(tree[i<<1].MAX,tree[i<<1|1].MAX);
    tree[i].MIN=min(tree[i<<1].MIN,tree[i<<1|1].MIN);
}
int ask(int i,int l,int r,int flag)
{
    if(tree[i].l==l&&tree[i].r==r)
    {
        return flag?tree[i].MAX:tree[i].MIN;
    }
    int mid=(tree[i].l+tree[i].r)/2;
    if(r<=mid)return ask(i<<1,l,r,flag);
    else if(l>mid)return ask(i<<1|1,l,r,flag);
    else
    {
        if(flag)return max(ask(i<<1,l,mid,flag),ask(i<<1|1,mid+1,r,flag));
        else return min(ask(i<<1,l,mid,flag),ask(i<<1|1,mid+1,r,flag));
    }
}




int main()
{
    scanf("%d%d",&n,&m);
    build(1,1,n);
    int l,r;
    while(m--)
    {
        scanf("%d%d",&l,&r);
        printf("%d\n",ask(1,l,r,1)-ask(1,l,r,0));
    }
    return 0;
}






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值