poj1159 Palindrome

Palindrome
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 60328 Accepted: 21010

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2

设原序列S的逆序列为S' ,则这道题目的关键在于,

最少需要补充的字母数 = 原序列S的长度 —  S和S'的最长公共子串长度
这个公式我不证明,不难证
剩下的就小意思了,最基础的LCS题。

注意本题空间开销非常大,需要适当的处理手法

23333,肯定不会超5000,所以开short。

遇到short肝不过去的就要考虑滚动滚动滚~咯

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <cmath>
#include <algorithm>
using namespace std;
const int MAXN=5000+5;
const int inf=0x3f3f3f;
int n;
char s1[MAXN],s2[MAXN];
short int dp[MAXN][MAXN];
int main()
{
    scanf("%d",&n);
    scanf("%s",s1);
    int i,j;
    for(i=0;i<n;++i)
    {
        s2[i]=s1[n-i-1];
    }
    s2[n]=0;

    for(i=0;i<=n;++i)
        for(j=0;j<=n;++j)
    {
        if(!i||!j)dp[i][j]=0;
        else
        {
            if(s1[i-1]==s2[j-1])dp[i][j]=dp[i-1][j-1]+1;
            else dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
        }
    }
    printf("%d\n",n-dp[n][n]);
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值