poj3109 Candies

Candies
Time Limit: 1500MS Memory Limit: 131072K
Total Submissions: 29659 Accepted: 8221

Description

During the kindergarten days, flymouse was the monitor of his class. Occasionally the head-teacher brought the kids of flymouse’s class a large bag of candies and had flymouse distribute them. All the kids loved candies very much and often compared the numbers of candies they got with others. A kid A could had the idea that though it might be the case that another kid B was better than him in some aspect and therefore had a reason for deserving more candies than he did, he should never get a certain number of candies fewer than B did no matter how many candies he actually got, otherwise he would feel dissatisfied and go to the head-teacher to complain about flymouse’s biased distribution.

snoopy shared class with flymouse at that time. flymouse always compared the number of his candies with that of snoopy’s. He wanted to make the difference between the numbers as large as possible while keeping every kid satisfied. Now he had just got another bag of candies from the head-teacher, what was the largest difference he could make out of it?

Input

The input contains a single test cases. The test cases starts with a line with two integers N and M not exceeding 30 000 and 150 000 respectively. N is the number of kids in the class and the kids were numbered 1 throughN. snoopy and flymouse were always numbered 1 and N. Then follow M lines each holding three integers AB and c in order, meaning that kid A believed that kid B should never get over c candies more than he did.

Output

Output one line with only the largest difference desired. The difference is guaranteed to be finite.

Sample Input

2 2
1 2 5
2 1 4

Sample Output

5

题意:n个人,m个约束条件,m行的a b c表示b这个人多余a这个人的糖果不会超过c个,问你1和n的最多可以差多少个糖果。

思路:

比较裸的差分约束,你把限制条件列出来dis[b]-dis[a]<=c建图直接求1-n的最短路就可以了。

注意:这个题光前向星还不够,队列也得用静态的,这地方开的空间得大点才行,不然就是RE,我直接用的栈来干的,因为前后更新的前后顺序不重要。

或者你直接用个循环队列就行了。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <queue>
#include <cmath>
using namespace std;
const int MAXN=30000+10;
const int inf=1e9;
int dis[MAXN],head[MAXN];
bool vis[MAXN];
struct ndoe
{
    int v;
    int w;
    int next;
}e[155555];
int n,m;
int cnt;
void add(int u,int v,int w)
{
    e[cnt].v=v;
    e[cnt].w=w;
    e[cnt].next=head[u];
    head[u]=cnt++;
}
void init()
{
    cnt=0;
    for(int i=1;i<=n;++i)head[i]=-1;
}

void spfa()
{
    int i;
    for(i=1;i<=n;++i)
    {
        dis[i]=inf;
        vis[i]=0;
    }
    int q[MAXN];
    int top=0;
    q[top++]=1;
    dis[1]=0;
    while(top)
    {
        int u=q[--top];
        vis[u]=0;
        for(i=head[u];i!=-1;i=e[i].next)
        {
            int v=e[i].v;
            int w=e[i].w;
            int t=dis[u]+w;
            if(dis[v]>t)
            {
                dis[v]=t;
                if(!vis[v])
                {
                    q[top++]=v;
                    vis[v]=1;
                }
            }
        }
    }
}

int main()
{
    int i;
    while(~scanf("%d%d",&n,&m))
    {
        int u,v,w;
        init();
        for(i=1;i<=m;++i)
        {
            scanf("%d%d%d",&u,&v,&w);
            add(u,v,w);
        }
        spfa();
        printf("%d\n",dis[n]);
    }
    return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值