poj3252 Round Numbers

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone' (also known as 'Rock, Paper, Scissors', 'Ro, Sham, Bo', and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can't even flip a coin because it's so hard to toss using hooves.

They have thus resorted to "round number" matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both "round numbers", the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a "round number" if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many "round numbers" are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input
Line 1: Two space-separated integers, respectively  Start and  Finish.
Output
Line 1: A single integer that is the count of round numbers in the inclusive range Start..  Finish
Sample Input
2 12
Sample Output
6


找到给定区间内,一个数转换成二进制数0的个数大于等于1的个数的数的个数。

嗯,感觉数位dp都是差不多一个套路,这一次就是换成二进制来搜素,注意前导0的情况。

搜索的时候dp[i][j1][j2]表示长度为i,0的个数为j1,1的个数为j2的数的个数。

//#include <bits/stdc++.h>
#include <cstdio>
#include <cstring>
using namespace std;
typedef long long LL;
const int MAXN=1e5+10;
int l,r;
int dp[50][50][50];
int digit[20];
int dfs(int len,int num0,int num1,bool up,bool zero)
{
    if(!len)return num0 >= num1;
    if(!up && dp[len][num0][num1] != -1)return dp[len][num0][num1];
    int res = 0;
    int n = up?digit[len] : 1;
    for(int i = 0 ; i <= n ; ++i)
    {
        if(zero)
        {
            if(i)res += dfs(len-1,0,1,up && i==n,0);
            else res += dfs(len-1,0,0,up && i==n,1);
        }
        else
        {
            if(i)res += dfs(len-1,num0,num1 + 1,up && i==n,0);
            else res += dfs(len-1,num0 + 1,num1,up && i==n,0);
        }
    }
    if(!up)dp[len][num0][num1] = res;
    return res;
}
int cal(int x)
{
    int len = 0;
    while(x)
    {
        digit[++len] = x & 1;
        x >>= 1;
    }
    return dfs(len,0,0,1,1);
}
int main()
{
    memset(dp,-1,sizeof dp);
    scanf("%d%d",&l,&r);
    printf("%d\n",cal(r) - cal(l-1));
    return 0;
}







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值