HDU 6038 Function

Function

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 607    Accepted Submission(s): 243


Problem Description
You are given a permutation  a  from  0  to  n1  and a permutation  b  from  0  to  m1 .

Define that the domain of function  f  is the set of integers from  0  to  n1 , and the range of it is the set of integers from  0  to  m1 .

Please calculate the quantity of different functions  f  satisfying that  f(i)=bf(ai)  for each  i  from  0  to  n1 .

Two functions are different if and only if there exists at least one integer from  0  to  n1  mapped into different integers in these two functions.

The answer may be too large, so please output it in modulo  109+7 .
 

Input
The input contains multiple test cases.

For each case:

The first line contains two numbers  n,   m (1n100000,1m100000)

The second line contains  n  numbers, ranged from  0  to  n1 , the  i -th number of which represents  ai1 .

The third line contains  m  numbers, ranged from  0  to  m1 , the  i -th number of which represents  bi1 .

It is guaranteed that  n106,   m106 .
 

Output
For each test case, output " Case # x y " in one line (without quotes), where  x  indicates the case number starting from  1  and  y  denotes the answer of corresponding case.
 

Sample Input
  
  
3 2 1 0 2 0 1 3 4 2 0 1 0 2 3 1
 

Sample Output
  
  
Case #1: 4 Case #2: 4

从集合b中选择n个数构成f[i],问符合f[i] = b[ f[ a[i] ]  ]的映射关系有多少种。

第一个样例  a={1,0,2}   b={0,1}

那么f(0)=b[f(1)]    f(1)=b[f(0)]    f(2)=b[f(2)]

这里有两个环分别为 f(0)->f(1)   和f(2)


那么要使得满足条件带入的b必须成环而且是 a环长度的因子

按照这个思路就可以得到答案了~


很套路的题。

#include <bits/stdc++.h>
using namespace std;
const int MAXN = 1e5+7;
const long long mod = 1e9+7;
int n,m;
bool vis[MAXN];
int a[MAXN],b[MAXN];
vector<int>circle_a,factor[MAXN];
//寻找环
int dfs(int u,int *p)
{
    if(vis[u])return 0;
    vis[u] = 1;
    return dfs(p[u],p) + 1;
}
//记录长度为下标的环的个数
int lenb[MAXN];
//得到因子
void get_factor()
{
    for(int i = 1; i <= 100000; ++i)
    {
        for(int j = i; j <= 100000; j += i)factor[j].push_back(i);
    }
}

int main()
{
    get_factor();
    int ca = 0;
    while(~scanf("%d%d",&n,&m))
    {
        for(int i = 0; i < n; ++i)scanf("%d",&a[i]);
        for(int i = 0; i < m; ++i)scanf("%d",&b[i]);
        circle_a.clear();
        memset(vis,0,sizeof vis);
        for(int i = 0; i < n; ++i)
        {
            if(vis[i])continue;
            circle_a.push_back(dfs(i,a));
        }
        memset(vis,0,sizeof vis);
        memset(lenb,0,sizeof lenb);
        for(int i = 0; i < m; ++i)
        {
            if(vis[i])continue;
            lenb[dfs(i,b)]++;;
        }
        long long ans = 1;
        for(int i = 0,l = circle_a.size(); i < l; ++i)
        {
            int la = circle_a[i];
            long long res = 0;
            for(int j = 0,l1 = factor[la].size(); j < l1; ++j)
            {
                int lb = factor[la][j];
                res = (res + (long long)lb*lenb[lb])%mod;
            }
            ans = ans*res%mod;
        }
        printf("Case #%d: %I64d\n",++ca,ans);
    }
    return 0;
}








评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值