1016 Phone Bills (25 分)

 

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar(日历) month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting(表示) the toll(通行费) (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (≤1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word on-lineor off-line.

For each test case, all dates will be within a single month. Each on-line record is paired with the chronologically(按时间先后顺序) next record for the same customer provided it is an off-line record. Any on-line records that are not paired with an off-line record are ignored, as are off-line records not paired with an on-line record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical(按字母顺序) order of customers' names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

Sample Output:

CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

参考代码:

 

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;

int toll[25];       //资费
const int maxn = 1010;
struct Record
{
  char name[25];          //姓名
  int month, dd, hh, mm;  //月、日、时、分
  bool status;            // true在线  
}rec[maxn],temp;

bool cmp(Record a, Record b){
  int s = strcmp(a.name, b.name);
  if(s != 0) return s < 0;            //优先按照姓名字典序从小到大排序
  else if(a.month != b.month) return a.month < b.month; //按照月份
  else if(a.dd != b.dd) return  a.dd < b.dd;            //按照日期
  else if(a.hh != b.hh) return a.hh < b.hh;             //按照小时
  else return a.mm < b.mm;                              //按照分钟
}

void get_ans(int on, int off, int& time, int& money){
  temp = rec[on];
  while(temp.dd < rec[off].dd || temp.hh < rec[off].hh || temp.mm < rec[off].mm){
    time++;                                 //记录总时间(分钟)
    money += toll[temp.hh];                 //话费增加
    temp.mm++;                              //当前时间加1min
    if(temp.mm >= 60){                      //当前分钟达60,进入下一小时
      temp.mm = 0;
      temp.hh++;
    }
    if(temp.hh >= 24){                      //当前小时达24,进入下一天
      temp.hh = 0;
      temp.dd++;
    }
  }
}

int main(int argc, char const *argv[])
{
  for (int i = 0; i < 24; ++i)
  {
    scanf("%d", &toll[i]);                  //资费
  }
  
  int N;
  char line[10];                           //临时存放off和on的输入
  scanf("%d", &N);
  for (int i = 0; i < N; ++i)
  {
    scanf("%s", rec[i].name);
    scanf("%d:%d:%d:%d", &rec[i].month, &rec[i].dd, &rec[i].hh, &rec[i].mm );
    scanf("%s", line);
    if(strcmp(line, "on-line") == 0){
        rec[i].status = true;
    }else{
        rec[i].status = false;
    }
  }

  sort(rec, rec + N, cmp);              //排序
  int on = 0, off, next;                //on和off为配对额两条记录,next为下一用户
  while(on < N)                         //每次循环处理单用户所有记录
  { 
    int needPrint = 0;
    next = on;
    while(next < N && strcmp(rec[next].name, rec[on].name) == 0){
      if(needPrint == 0 && rec[next].status == true){
        needPrint = 1;                  //找到on置为1
    }
   else if(needPrint == 1 && rec[next].status == false){
      needPrint = 2;                    //on之后找到off 置为2
    }
    next++;                             //next自增,直到找到下一用户
    }
    
    if(needPrint < 2){                  //没有找到配对的on和off
      on = next;
      continue;
    }

    int allMoney = 0;
    printf("%s %02d\n", rec[on].name, rec[on].month);

    while(on < next){                  //寻找该用户的所有配对
      while(on < next - 1 && !(rec[on].status == true && rec[on + 1].status == false)){
          on++;
      }                                 //直到找到连续的on和off
       off = on + 1;
    if(off == next){
      on = next;
      break;
    }
    printf("%02d:%02d:%02d ", rec[on].dd, rec[on].hh, rec[on].mm);
    printf("%02d:%02d:%02d ", rec[off].dd, rec[off].hh, rec[off].mm);
    int time = 0;                     //时间
    int money = 0;                    //单次记录话费的钱
    get_ans(on, off, time, money);    //记录on到off内的时间和金钱
    allMoney += money;
    printf("%d $%.2f\n", time, money/100.0);
    on = off + 1;                     //完成配对,从off+1开始寻找下一对
    }
printf("Total amount: $%.2f\n", allMoney / 100.0);
  }
  return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

繁星蓝雨

如果觉得文章不错,可以请喝咖啡

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值