PyQt5安装及ModuleNotFoundError: No module named 'PyQt5'问题解决

安装pyQt5费了很多的周折,不过现在还是安装好了,现在重新梳理一下整个安装过程,注意我使用的是win7操作系统。


1、登录Python官网,目前最新的版本是3.6.3,网址为:https://www.python.org/downloads/release/python-363/

选中Windows x86-64 executalbe installer,将其下载下来,由于是可执行文件,直接安装即可。


2、安装时,一定要选择pip,将其安装上



3、安装成功后,可以在cmd窗口中试一下pip命令,如果没有问题,我们要先安装sip,具体命令如下:

pip3 install sip


4、下面就可以安装PyQt5了,使用下列命令

pip3 install PyQt5


使用上述命令,可以自动去官网查找与Python版本号相同的程序进行下载,比较方便,如果不是这样也可从PyQt官网上下载与Python相匹配的程序文件。

如果是自己手动下载的pyqt5并且安装了,可能会版本不匹配,可以做如下处理

是自己手动安装的PyQt5的版本,与Python版本不匹配,后来用pip3 install PyQt5命令升级到相匹配的版本后,但是sip没有做版本适应。

解决此问题的方法是,先卸载sip,命令为:

pip3 uninstall sip

然后再安装一次即可,命令为

pip3 install sip

、、、、、、、、、、、、、、、、、、、、、、、、、、、、、、、、、、、、、、、、、、、、、、、、、、

下面是解决

ModuleNotFoundError: No module named 'pyqt5'问题

PyCharm不识别PyQt5的问题如图所示,引用PyQt5的时候显示错误“ModuleNotFoundError: No module named 'pyqt5'”

首先确定已经安装了PyQt5是成功的

Python\Python36\Lib\site-packages这个路径下面去看有没有PyQt5相关的库


通过python的命令引用PyQt5成功,表示PyQt5安装没有问题

Python环境变量配置一般没有问题,很少,如果有,就无法运行


最新版的PyCharm,因为高版本pycharm自己创建了一个Python虚拟环境 默认没有把你安装的第三方库添加进来,所以就造成这种问题,而且在新建项目时候Project Iterpreter那个标签隐藏,无法注意到,需要手动打开,如下图中绿色那个小东西打开:

解决办法1:在新建项目的时候如下图所示勾选那两个框框,目的是加载第三方库


这样在创建完工程的时候会加载一堆东西,另一个办法就是利用下面的Existing interpreter来处理。点击那个配置按钮

如果你已经建了项目,不想重新再重复已有的工作,别担心,还有办法!


在已有项目的最后面找到External Libraries ,然后找到venv目录,把pyvenv.cfg文件中的如下参数改成true

include-system-site-packages = true

大功告成!

如果你没有找到pyvenv.cfg,那么在你的settings->projiect interpreter目录所在处,找到该文件,用记事本修改完后,保存即可


展开阅读全文

没有更多推荐了,返回首页