HDU 2120 Ice_cream's world I

Description

ice_cream's world is a rich country, it has many fertile lands. Today, the queen of ice_cream wants award land to diligent ACMers. So there are some watchtowers are set up, and wall between watchtowers be build, in order to partition the ice_cream’s world. But how many ACMers at most can be awarded by the queen is a big problem. One wall-surrounded land must be given to only one ACMer and no walls are crossed, if you can help the queen solve this problem, you will be get a land.
 

Input

In the case, first two integers N, M (N<=1000, M<=10000) is represent the number of watchtower and the number of wall. The watchtower numbered from 0 to N-1. Next following M lines, every line contain two integers A, B mean between A and B has a wall(A and B are distinct). Terminate by end of file.
 

Output

Output the maximum number of ACMers who will be awarded. 
One answer one line.
 

Sample Input

    
    
8 10 0 1 1 2 1 3 2 4 3 4 0 5 5 6 6 7 3 6 4 7
 

Sample Output

    
    
3
 

原谅我其实看不懂题。

题意:问在一个图中,有几个环;(应该是这样)

小希同学那道题中判断环的思想,直接ans++;

AC代码:

#include <bits/stdc++.h>
using namespace std ;
int n , m , pre[2000],vis[2000],ans;
int find ( int x )
{
	if(x!=pre[x])
	return pre[x]=find(pre[x]);
	return x ;
}
void mix(int x , int y )
{
	int dx = find(x);
	int dy = find(y);
	if(dx!=dy)
	{
		pre[dy]=dx;
	}
	else ans++;
}
int main()
{
	while(cin>>n>>m)
	{
		ans = 0 ;
		for(int i = 0 ; i<n;i++)
		{
			vis[i]=0;
			pre[i]=i;
		}
		for(int i= 0 ; i < m ; i++)
		{
			int a , b ;
			cin>>a>>b;
			mix(a,b);
		}
		cout<<ans<<endl;
	}
	return 0 ;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Kelisita

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值