LCS变形+基因匹配问题(1080)

Human Gene Functions

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2915    Accepted Submission(s): 1645


Problem Description
It is well known that a human gene can be considered as a sequence, consisting of four nucleotides, which are simply denoted by four letters, A, C, G, and T. Biologists have been interested in identifying human genes and determining their functions, because these can be used to diagnose human diseases and to design new drugs for them.

A human gene can be identified through a series of time-consuming biological experiments, often with the help of computer programs. Once a sequence of a gene is obtained, the next job is to determine its function. One of the methods for biologists to use in determining the function of a new gene sequence that they have just identified is to search a database with the new gene as a query. The database to be searched stores many gene sequences and their functions – many researchers have been submitting their genes and functions to the database and the database is freely accessible through the Internet.

A database search will return a list of gene sequences from the database that are similar to the query gene. Biologists assume that sequence similarity often implies functional similarity. So, the function of the new gene might be one of the functions that the genes from the list have. To exactly determine which one is the right one another series of biological experiments will be needed.

Your job is to make a program that compares two genes and determines their similarity as explained below. Your program may be used as a part of the database search if you can provide an efficient one.

Given two genes AGTGATG and GTTAG, how similar are they? One of the methods to measure the similarity of two genes is called alignment. In an alignment, spaces are inserted, if necessary, in appropriate positions of the genes to make them equally long and score the resulting genes according to a scoring matrix.

For example, one space is inserted into AGTGATG to result in AGTGAT-G, and three spaces are inserted into GTTAG to result in –GT--TAG. A space is denoted by a minus sign (-). The two genes are now of equal length. These two strings are aligned:

AGTGAT-G
-GT--TAG

In this alignment, there are four matches, namely, G in the second position, T in the third, T in the sixth, and G in the eighth. Each pair of aligned characters is assigned a score according to the following scoring matrix.

* denotes that a space-space match is not allowed. The score of the alignment above is (-3)+5+5+(-2)+(-3)+5+(-3)+5=9.

Of course, many other alignments are possible. One is shown below (a different number of spaces are inserted into different positions):

AGTGATG
-GTTA-G

This alignment gives a score of (-3)+5+5+(-2)+5+(-1) +5=14. So, this one is better than the previous one. As a matter of fact, this one is optimal since no other alignment can have a higher score. So, it is said that the similarity of the two genes is 14.
 

Input
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case consists of two lines: each line contains an integer, the length of a gene, followed by a gene sequence. The length of each gene sequence is at least one and does not exceed 100.
 

Output
The output should print the similarity of each test case, one per line.
 

Sample Input
  
  
2 7 AGTGATG 5 GTTAG 7 AGCTATT 9 AGCTTTAAA
 

Sample Output
  
  
14 21

LCS加强版,设dp[i][j]表示s串前i个,t串前j个所能形成的最大相似度。和LCS一样,解法可以通过一张表格理解。当决策到dp[i][j]时,①s串取第i个,t串取第j个,所以贡献是dp[i-1][j-1]+value[w(s[i])][w(t[j])] ; ②s串取'-',t串取第j个,贡献是dp[i][j-1]+value[w('-')][w(t[j])] 。这里有一点难理解:此处是让横线'-'和t[j]对齐,前面的dp值又是个子问题,子问题求解的时候也会让两串长度相等,所以这里暗含着两串长度相等在里面,i和j从小到大遍历保证了子问题直接可得; ③s串取第i个,t串取'-',贡献是dp[i-1][j]+value[w(s[i])][w('-')] 。最后的dp[i][j]只要取三者最大即可。这道题还有个关键点是初始化的问题。

/*------------------Header Files------------------*/
#include <iostream>
#include <cstring>
#include <string>
#include <cstdio>
#include <algorithm>
#include <cstdlib>
#include <ctype.h>
#include <cmath>
#include <stack>
#include <queue>
#include <map>
#include <vector>
#include <limits.h>
using namespace std;
/*------------------Definitions-------------------*/
#define LL long long
#define PI acos(-1.0)
#define INF 0x3F3F3F3F
#define MOD 10E9+7
#define MAX 500050
/*---------------------Work-----------------------*/
int n,m;
char s[150],t[150];
int dp[150][150];
int value[5][5]={5,-1,-2,-1,-3,
				 -1,5,-3,-2,-4,
				 -2,-3,5,-2,-2,
				 -1,-2,-2,5,-1,
				 -3,-4,-2,-1};
int w(char ch)
{
	if(ch=='A') return 0;
	else if(ch=='C') return 1;
	else if(ch=='G') return 2;
	else if(ch=='T') return 3;
	else if(ch=='-') return 4;
}
int MaxOfThree(int a,int b,int c)
{
	return max(a,max(b,c));
}
void work()
{
	int T; cin>>T;
	while(T--)
	{
		scanf("%d",&n);
		getchar();
		for(int i=1;i<=n;i++)
			scanf("%c",&s[i]);
		scanf("%d",&m);
		getchar();
		for(int i=1;i<=m;i++)
			scanf("%c",&t[i]);
		memset(dp,0,sizeof(dp));
		for(int i=1;i<=n;i++)
			dp[i][0]=dp[i-1][0]+value[w(s[i])][w('-')];
		for(int i=1;i<=m;i++)
			dp[0][i]=dp[0][i-1]+value[w('-')][w(t[i])];
		int ans1,ans2,ans3;
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=m;j++)
			{
				ans1=dp[i-1][j-1]+value[w(s[i])][w(t[j])];
				ans2=dp[i-1][j]+value[w(s[i])][w('-')];
				ans3=dp[i][j-1]+value[w('-')][w(t[j])];
				dp[i][j]=MaxOfThree(ans1,ans2,ans3);
			}
		}
		printf("%d\n",dp[n][m]);
	}
}
/*------------------Main Function------------------*/
int main()
{
	//freopen("test.txt","r",stdin);
	//freopen("cowtour.out","w",stdout);
	//freopen("cowtour.in","r",stdin);
	work();
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值