重叠子问题+状压DP(位压缩)(1074)


Doing Homework

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7104    Accepted Submission(s): 3127


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test, 1 day for 1 point. And as you know, doing homework always takes a long time. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=15) which indicate the number of homework. Then N lines follow. Each line contains a string S(the subject's name, each string will at most has 100 characters) and two integers D(the deadline of the subject), C(how many days will it take Ignatius to finish this subject's homework).

Note: All the subject names are given in the alphabet increasing order. So you may process the problem much easier.
 

Output
For each test case, you should output the smallest total reduced score, then give out the order of the subjects, one subject in a line. If there are more than one orders, you should output the alphabet smallest one.
 

Sample Input
  
  
2 3 Computer 3 3 English 20 1 Math 3 2 3 Computer 3 3 English 6 3 Math 6 3
 

Sample Output
  
  
2 Computer Math English 3 Computer English Math

本题的巧妙之处在于将所有状态压缩在一个数字中,状态压缩DP中的位压缩。针对众多的重叠子问题,DP做出了极大的优化,记录dp[sta]为状态为sta时的最小惩罚,DP方程为dp[sta|(1<<i)]=min(dp[sta|(1<<i),dp[sta]+max(0,sum+time[i]-ddl[i])),其中sum表示当前状态已经消耗的时间,内层函数从小到大遍历意思是在sta状态时下一个任务做第i个的最优解,max函数的含义是只有正值才有效(很快完成一个任务并不能减小惩罚)。另外,此题要注意操作符的优先级,不确定的话可以多加括号。


/*------------------Header Files------------------*/
#include <iostream>
#include <cstring>
#include <string>
#include <cstdio>
#include <algorithm>
#include <cstdlib>
#include <ctype.h>
#include <cmath>
#include <stack>
#include <queue>
#include <map>
#include <vector>
#include <limits.h>
using namespace std;
/*------------------Definitions-------------------*/
#define LL long long
#define PI acos(-1.0)
#define INF 0x3F3F3F3F
#define MOD 10E9+7
#define MAX 500050
/*---------------------Work-----------------------*/
int N;
char home[20][150];
int ddl[20],time[20];
int pre[(1<<15)+10],dp[(1<<15)+10];
void print(int sta) //输出路径
{
	if(sta==0) return ;
	int u;
	for(int i=0;i<N;i++)
	{
		if((pre[sta]&(1<<i))==0&&((sta&(1<<i))!=0))
		{
			u=i;
			break;
		}
	}
	print(pre[sta]);
	printf("%s\n",home[u]);
} 
void work()
{
	int T; cin>>T;
	while(T--)
	{
		scanf("%d",&N);
		for(int i=0;i<N;i++)
			scanf("%s%d%d",home[i],&ddl[i],&time[i]);
		memset(dp,0x3F,sizeof(dp));
		memset(pre,0,sizeof(pre));
		//for(int i=0;i<N;i++)
		//	printf("%s %d %d\n",home[i],ddl[i],time[i]);
		dp[0]=0;
		for(int sta=0;sta<(1<<N);sta++)
		{
			int sum=0;
			for(int i=0;i<N;i++)
				if(sta&(1<<i)) sum+=time[i];
			//printf("%d\n",sum);
			for(int i=0;i<N;i++)
			{
				if((sta&(1<<i))==0)
				{
					if(dp[sta|(1<<i)]>dp[sta]+max(0,sum+time[i]-ddl[i]))
					{
						dp[sta|(1<<i)]=dp[sta]+max(0,sum+time[i]-ddl[i]);
						pre[sta|(1<<i)]=sta;
					}
				}
			}
		}
		//for(int i=0;i<(1<<N);i++)
		//	printf("%d\n",dp[i]);
		printf("%d\n",dp[(1<<N)-1]);
		print((1<<N)-1);
	}
}
/*------------------Main Function------------------*/
int main()
{
	//freopen("test.txt","r",stdin);
	//freopen("cowtour.out","w",stdout);
	//freopen("cowtour.in","r",stdin);
	work();
	return 0;
}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值