LCS加强版+输出路径(1503)

Advanced Fruits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2367    Accepted Submission(s): 1208
Special Judge


Problem Description
The company "21st Century Fruits" has specialized in creating new sorts of fruits by transferring genes from one fruit into the genome of another one. Most times this method doesn't work, but sometimes, in very rare cases, a new fruit emerges that tastes like a mixture between both of them.
A big topic of discussion inside the company is "How should the new creations be called?" A mixture between an apple and a pear could be called an apple-pear, of course, but this doesn't sound very interesting. The boss finally decides to use the shortest string that contains both names of the original fruits as sub-strings as the new name. For instance, "applear" contains "apple" and "pear" (APPLEar and apPlEAR), and there is no shorter string that has the same property.

A combination of a cranberry and a boysenberry would therefore be called a "boysecranberry" or a "craboysenberry", for example.

Your job is to write a program that computes such a shortest name for a combination of two given fruits. Your algorithm should be efficient, otherwise it is unlikely that it will execute in the alloted time for long fruit names.
 

Input
Each line of the input contains two strings that represent the names of the fruits that should be combined. All names have a maximum length of 100 and only consist of alphabetic characters.

Input is terminated by end of file.
 

Output
For each test case, output the shortest name of the resulting fruit on one line. If more than one shortest name is possible, any one is acceptable.
 

Sample Input
  
  
apple peach ananas banana pear peach
 

Sample Output
  
  
appleach bananas pearch

pre数组用于输出路径,0,-1,1三个值分别代表三种状态转移。首先求出LCS,并标记出转移方向。最后需要输出路径:如果相等跳两个输出一个即可;如果横向大,则输出纵向,跳一个;纵向同理。即可得到所求。这个过程很有利于深入理解LCS。


/*------------------Header Files------------------*/
#include <iostream>
#include <cstring>
#include <string>
#include <cstdio>
#include <algorithm>
#include <cstdlib>
#include <ctype.h>
#include <cmath>
#include <stack>
#include <queue>
#include <map>
#include <vector>
#include <limits.h>
using namespace std;
/*------------------Definitions-------------------*/
#define LL long long
#define PI acos(-1.0)
#define INF 0x3F3F3F3F
#define MOD 10E9+7
#define MAX 500050
/*---------------------Work-----------------------*/
char a[150],b[150];
int pre[150][150],dp[150][150];
void print(int x,int y)
{
	if(x==0&&y==0) return ;
	if(pre[x][y]==0)
	{
		print(x-1,y-1);
		printf("%c",a[x]);
	}
	else if(pre[x][y]==1)
	{
		print(x-1,y);
		printf("%c",a[x]);
	}
	else if(pre[x][y]==-1)
	{
		print(x,y-1);
		printf("%c",b[y]);
	}
}
void work()
{
	while(~scanf("%s%s",a+1,b+1)) //下标从1开始,~没加OLE一次 
	{
		int lena=strlen(a+1),lenb=strlen(b+1);
		//方向初始化 
		for(int i=0;i<=lena;i++) pre[i][0]=1;
		for(int i=0;i<=lenb;i++) pre[0][i]=-1;
		memset(dp,0,sizeof(dp));
		for(int i=1;i<=lena;i++)
			for(int j=1;j<=lenb;j++)
			{
				if(a[i]==b[j])
				{
					dp[i][j]=dp[i-1][j-1]+1;
					pre[i][j]=0;
				}
				else if(dp[i-1][j]>dp[i][j-1])
				{
					dp[i][j]=dp[i-1][j];
					pre[i][j]=1;
				}
				else
				{
					dp[i][j]=dp[i][j-1];
					pre[i][j]=-1;
				}
			}
		print(lena,lenb);
		printf("\n");
	}
}
/*------------------Main Function------------------*/
int main()
{
	//freopen("test.txt","r",stdin);
	//freopen("cowtour.out","w",stdout);
	//freopen("cowtour.in","r",stdin);
	work();
	return 0;
}



  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
最长公共子序列(LCS)是两个序列中都存在的最长子序列。为了修改算法 LCS 使其输出最长公共子序列,我们需要在 LCS 算法的基础上进行一些修改,具体步骤如下: 1. 构造一个二维数组 dp,其中 dp[i][j] 表示序列 A 中前 i 个元素和序列 B 中前 j 个元素的最长公共子序列长度。 2. 初始化 dp 数组的第一行和第一列,即 dp[0][j] 和 dp[i][0] 均为 0。 3. 对于序列 A 和序列 B 中的每一个元素,判断它们是否相等。 4. 如果 A[i] 和 B[j] 相等,则 dp[i][j] = dp[i-1][j-1] + 1。 5. 如果 A[i] 和 B[j] 不相等,则 dp[i][j] = max(dp[i-1][j], dp[i][j-1])。 6. 最终,最长公共子序列的长度为 dp[m][n],其中 m 和 n 分别为序列 A 和序列 B 的长度。 7. 根据 dp 数组求出最长公共子序列。从 dp[m][n] 开始,如果 A[i] 和 B[j] 相等,则将该元素加入最长公共子序列中,然后向左上方移动一格,即 i--,j--;如果不相等,则向较大的方向移动一格。 代码如下: ```python def LCS(A, B): m, n = len(A), len(B) dp = [[0] * (n+1) for _ in range(m+1)] # 构造二维数组 for i in range(1, m+1): for j in range(1, n+1): if A[i-1] == B[j-1]: dp[i][j] = dp[i-1][j-1] + 1 else: dp[i][j] = max(dp[i-1][j], dp[i][j-1]) # 求最长公共子序列 lcs = '' i, j = m, n while i > 0 and j > 0: if A[i-1] == B[j-1]: lcs = A[i-1] + lcs i -= 1 j -= 1 elif dp[i-1][j] > dp[i][j-1]: i -= 1 else: j -= 1 return lcs ``` 该算法的时间复杂度为 $O(mn)$,其中 m 和 n 分别为序列 A 和序列 B 的长度。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值