poj2342 Anniversary party

Language:
Anniversary party
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6480 Accepted: 3734

Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0 

Output

Output should contain the maximal sum of guests' ratings.

Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output

5
题目的大致意思是某高校要办校庆,为了使场面尽可能活跃,校长考虑某位员工和他(她)的直接上司不能同时参加,每位员工的活跃度和关系已知(输入)。求活跃度的最大值。(这个关系显然是树,故称为树状dp?应该吧。。。)

分析:

每位员工有两种决策,来或者不来(分别用1和0表示),记dp[i][1](或dp[i][0])表示以i为根的子树能有最大的活跃值,其中dp[i][1]表示i来的情况,dp[i][0]表示i不来的情况。则由如下递推关系式:

dp[i][1]+=dp[j][0];//i是j的上司,i来,j不来。

dp[i][0]+=max(dp[j][1],dp[j][0]);//i是j的上司,i不来,j来或者不来。

记整棵树的根结点为root,则所求即为max(dp[root][1],dp[root][0])。

AC代码如下:

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
#define maxn 6005
#define max(a,b) (a>b)?a:b
int n;
int dp[maxn][2];
int father[maxn];
int visited[maxn];
void solve(int node)
{
    visited[node]=1;
    for(int i=1;i<=n;i++){
        if(!visited[i]&&father[i]==node){//i是node的下属
            solve(i);
            dp[node][1]+=dp[i][0];//上司去,下属不去。
            dp[node][0]+=max(dp[i][1],dp[i][0]);//上司不去,下属可以去也可以不去
        }
    }
}
int main()
{
    scanf("%d",&n);
    memset(dp,0,sizeof(dp));
    memset(visited,0,sizeof(visited));
    memset(father,0,sizeof(father));
    for(int i=1;i<=n;i++) scanf("%d",&dp[i][1]);
    int c,f,root;
    while(scanf("%d%d",&c,&f)&&(c||f)){
        father[c]=f;
        if(root==c||true){
                root=f;
        }
    }
    while(father[root]){//查找根结点
        root=father[root];
    }
    solve(root);
    printf("%d\n",max(dp[root][1],dp[root][0]));
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值