Description
Jessica's a very lovely girl wooed by lots of boys. Recently she has a problem. The final exam is coming, yet she has spent little time on it. If she wants to pass it, she has to master all ideas included in a very thick text book. The author of that text book, like other authors, is extremely fussy about the ideas, thus some ideas are covered more than once. Jessica think if she managed to read each idea at least once, she can pass the exam. She decides to read only one contiguous part of the book which contains all ideas covered by the entire book. And of course, the sub-book should be as thin as possible.
A very hard-working boy had manually indexed for her each page of Jessica's text-book with what idea each page is about and thus made a big progress for his courtship. Here you come in to save your skin: given the index, help Jessica decide which contiguous part she should read. For convenience, each idea has been coded with an ID, which is a non-negative integer.
Input
The first line of input is an integer P (1 ≤ P ≤ 1000000), which is the number of pages of Jessica's text-book. The second line contains P non-negative integers describing what idea each page is about. The first integer is what the first page is about, the second integer is what the second page is about, and so on. You may assume all integers that appear can fit well in the signed 32-bit integer type.
Output
Output one line: the number of pages of the shortest contiguous part of the book which contains all ideals covered in the book.
Sample Input
5 1 8 8 8 1
Sample Output
2题目大意 :一本书有P页,每页有个知识点,知识点可以重复。问至少连续读几页,使得覆盖全部知识点。
注意深刻理解一下尺取法,尺取法是只要不符合条件,e就在while里不断后移,如果符合条件s不断后移,直到不符合条件
下面是最简洁代码
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <set>
#include <map>
using namespace std;
const int maxn = 1e6 + 5;
int a[maxn];
int main()
{
int n;
while(~scanf("%d",&n))
{
// memset(book,0,sizeof(book));
set<int> S;
for(int i = 1; i <= n; i++)
{
scanf("%d",&a[i]);
S.insert(a[i]);
}
int sum = S.size();
int s, e;
s = e = 1;
int ans = 0;
int rec = 0x7fffffff;
map<int,int> book;
while(1)
{
while(ans < sum && e < n + 1)
{
if(!book[a[e++]]++)
ans++;
}
if(ans < sum) break;
// ` cout << sum << ' ' << s << ' ' << e << endl;
rec = min(rec,e-s);
if(--book[a[s++]] == 0)
ans--;
}
cout << rec << endl;
}
return 0;
}
以及一个出现经典错误的代码
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <set>
using namespace std;
const int maxn = 1e6 + 5;
int book[maxn], a[maxn]; //每个数字都在int范围内,无法用book记录,这时候可以用map啊~
int main()
{
int n;
while(~scanf("%d",&n))
{
memset(book,0,sizeof(book));
set<int> S;
for(int i = 1; i <= n; i++)
{
scanf("%d",&a[i]);
S.insert(a[i]);
}
int sum = S.size();
int s, e;
s = e = 1;
int ans = 0;
int rec = 0x7fffffff;
while(1)
{
while(ans < sum && e < n + 1)
{
if(!book[a[e]]++)
ans++,e++; //这里就是尺取法理解不深刻,以为符合条件才移动,其实是一直移动的
}
if(ans < sum) break;
// ` cout << sum << ' ' << s << ' ' << e << endl;
rec = min(rec,e-s);
if(--book[a[s]] == 0)
ans--,s++; //
}
cout << rec << endl;
}
return 0;
}