POJ 3041 Asteroids(最小点覆盖)



Asteroids
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 22644 Accepted: 12269

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS: 
The following diagram represents the data, where "X" is an asteroid and "." is empty space: 
X.X 
.X. 
.X.
 

OUTPUT DETAILS: 
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).



题意:给一个N*N的矩阵,有些格子有障碍,要求我们消除这些障碍,问每次消除一行或一列的障碍,最少要几次。


思路:关键是构图,把每行看作X集合中的一个点,每列看作Y集合中的一个点,这样每个障碍的行号列号对应连接


XY集合的一条边。现在要用最少点的点覆盖所有的障碍(也就是边),这就变成了最小顶点覆盖问题了。最小顶点数


=最大匹配。


一些矩形里最少多少次删除操作,都可以往这想想, 矩形里,列跟行分开想是很经常的,  列行拆点, 枚举一个利用特性做另一个,还有就是列行做二分图~ 一些两个东西对立的都可以想想匹配,两个东西的就可以想想了~


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
using namespace std;
const int maxn = 505;
vector<int> v[maxn];
int n, m, k, book[maxn], match[maxn];
int Find(int x)
{
    for(int i = 0; i < v[x].size(); i++)
    {
        int to = v[x][i];
        if(book[to]) continue;
        book[to] = 1;
        if(!match[to] || Find(match[to]))
        {
            match[to] = x;
            return 1;
        }
    }
    return 0;
}
int main()
{
    while(~scanf("%d%d", &n, &k))
    {
        int x, y, ans = 0;
        memset(match, 0, sizeof(match));
        for(int i = 0; i < maxn; i++)
            v[i].clear();
        for(int i = 1; i <= k; i++)
        {
            scanf("%d%d", &x, &y);
            v[x].push_back(y);
        }
        for(int i = 1; i <= n; i++)
        {
            memset(book, 0, sizeof(book));
            ans += Find(i);
        }
        printf("%d\n", ans);
    }
    return 0;
}



题意:给一个N*N的矩阵,有些格子有障碍,要求我们消除这些障碍,问每次消除一行或一列的障碍,最少要几次。


思路:关键是构图,把每行看作X集合中的一个点,每列看作Y集合中的一个点,这样每个障碍的行号列号对应连接


XY集合的一条边。现在要用最少点的点覆盖所有的障碍(也就是边),这就变成了最小顶点覆盖问题了。最小顶点数


=最大匹配。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值