4407: 于神之怒加强版
Time Limit: 80 Sec Memory Limit: 512 MBSubmit: 355 Solved: 174
[ Submit][ Status][ Discuss]
Description
给下N,M,K.求
Input
输入有多组数据,输入数据的第一行两个正整数T,K,代表有T组数据,K的意义如上所示,下面第二行到第T+1行,每行为两个正整数N,M,其意义如上式所示。
Output
如题
Sample Input
1 2
3 3
3 3
Sample Output
20
HINT
1<=N,M,K<=5000000,1<=T<=2000
题解:JudgeOnline/upload/201603/4407.rar
从枚举最大公因数的角度出发列出公式,莫比乌斯反演得到:
Ans=∑T=1n⌊nT⌋⌊mT⌋∑d∣Tdkμ(Td)
具体推演过程见:http://blog.csdn.net/phenix_2015/article/details/50783369
然后设G(T)=∑d∣Tdkμ(Td)
G(T)是积性函数,推到出线性筛公式:
a. 若T为素数,G(T)=T^k-1
b.若T为互质两数p,q乘积,G(T)=G(q)*G(p)
c.否则G(x*q)=G[x]*(q^k) ------->p为质数
那么线性筛处理G(T)后求前缀和,函数分块求ans
膜http://blog.csdn.net/phenix_2015/article/details/50783369
代码:
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<cstdio>
#include<string>
#include<climits>
#include<queue>
#include<stack>
#include<map>
#include<set>
#define N 5000100
#define mod 1000000007
using namespace std;
typedef long long ll;
ll T,n,m,k,ans;
ll mu[N],g[N],prime[N],cnt;
bool is[N];ll pw[N];
ll qm(ll a,ll b)
{
long long ret=1,t=a;
while(b)
{
if(b&1)ret=ret*t%mod;
t=t*t%mod;b>>=1;
}return ret;
}
void init()
{
g[1]=1;
for(ll i=2;i<N;i++)
{
if(!is[i])
{
prime[++cnt]=i;
pw[cnt]=qm(i,k);
g[i]=pw[cnt]-1;
}
for(ll j=1;j<=cnt;j++)
{
long long t=prime[j]*i;
if(t>=N)break;is[t]=1;
if(i%prime[j]==0){g[t]=g[i]*pw[j]%mod;break;}
g[t]=g[i]*g[prime[j]]%mod;
}
}for(ll i=2;i<N;i++)g[i]=(g[i]+g[i-1])%mod;
}
void solve(ll n,ll m)
{
ans=0;if(n>m)swap(n,m);
ll last=0;
for(ll i=1;i<=n;i=last+1)
{
last=min(n/(n/i),m/(m/i));
(ans+=(n/i)*(m/i)%mod*(g[last]-g[i-1]+mod)%mod)%=mod;
}
}
int main()
{
scanf("%lld%lld",&T,&k);init();
while(T--)
{
scanf("%lld%lld",&n,&m);
solve(n,m);printf("%lld\n",ans);
}
}
ns=∑T=1n⌊nT⌋⌊mT⌋∑d∣Tdkμ(Td)