HDU 1253 (BFS) 胜利大逃亡

Problem Description
Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会.

魔王住在一个城堡里,城堡是一个A*B*C的立方体,可以被表示成A个B*C的矩阵,刚开始Ignatius被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在T分钟后回到城堡,Ignatius每分钟能从一个坐标走到相邻的六个坐标中的其中一个.现在给你城堡的地图,请你计算出Ignatius能否在魔王回来前离开城堡(只要走到出口就算离开城堡,如果走到出口的时候魔王刚好回来也算逃亡成功),如果可以请输出需要多少分钟才能离开,如果不能则输出-1.


 

Input
输入数据的第一行是一个正整数K,表明测试数据的数量.每组测试数据的第一行是四个正整数A,B,C和T(1<=A,B,C<=50,1<=T<=1000),它们分别代表城堡的大小和魔王回来的时间.然后是A块输入数据(先是第0块,然后是第1块,第2块......),每块输入数据有B行,每行有C个正整数,代表迷宫的布局,其中0代表路,1代表墙.(如果对输入描述不清楚,可以参考Sample Input中的迷宫描述,它表示的就是上图中的迷宫)

特别注意:本题的测试数据非常大,请使用scanf输入,我不能保证使用cin能不超时.在本OJ上请使用Visual C++提交.
 

Output
对于每组测试数据,如果Ignatius能够在魔王回来前离开城堡,那么请输出他最少需要多少分钟,否则输出-1.
 

Sample Input
   
   
1 3 3 4 20 0 1 1 1 0 0 1 1 0 1 1 1 1 1 1 1 1 0 0 1 0 1 1 1 0 0 0 0 0 1 1 0 0 1 1 0
 

Sample Output
   
   
11

最短路,bfs,也可以判断最短路和t之间的关系,在过程中剪枝,但比较懒,就没有写

#include <iostream>
#include <cstdio>
#include <queue>
#include <cstring>
#include <fstream>
int a, b, c, t;
int map[55][55][55];
int vis[55][55][55];
int dir[6][3] = {{0, 0, 1}, {0, 0, -1}, {0, 1, 0}, {0, -1, 0}, {1, 0, 0}, {-1, 0, 0}};
using namespace std;

struct node{
    int x, y, z;
    int dis;
    node(int x, int y, int z, int dis) : x(x), y(y), z(z), dis(dis){}
};
int bfs()
{
    memset(vis, 0, sizeof(vis));
    queue<node> q;
    q.push(node(0, 0, 0, 0));
    vis[0][0][0] = 1;
    while(q.size())
    {
        node p = q.front();
        q.pop();
        if(p.x == a - 1 && p.y == b - 1 && p.z == c - 1)
        {
            return p.dis;
        }
        for(int i = 0; i < 6; i++)
        {
            int xx = p.x + dir[i][0];
            int yy = p.y + dir[i][1];
            int zz = p.z + dir[i][2];
            if(xx >= 0 && xx < a && yy >= 0 && yy < b && zz >= 0 && zz < c && !vis[xx][yy][zz] && map[xx][yy][zz] == 0 && p.dis < t)
            {
                vis[xx][yy][zz] = 1;
                q.push(node(xx, yy, zz, p.dis + 1));
            }
        }
    }
    return -1;
}
int main()
{
    //freopen("in.txt", "r", stdin);
    int k;
    scanf("%d", &k);
    while(k)
    {
        k--;
        scanf("%d%d%d%d", &a, &b, &c, &t);
        for(int i = 0; i < a; i++)
        {
            for(int j = 0; j < b; j++)
            {
                for(int k = 0; k < c; k++)
                {
                    scanf("%d", &map[i][j][k]);
                }
            }
        }
        int n = bfs();
        if(n <= t)
        {
            printf("%d\n", n);
        }
        else
        {
            printf("-1\n");
        }
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值