Wet Shark and Odd and Even


Wet Shark and Odd and Even

Crawling in process... Crawling failed Time Limit:2000MS     Memory Limit:262144KB     64bit IO Format:%I64d & %I64u

Description

Today, Wet Shark is given n integers. Using any of these integers no more than once, Wet Shark wants to get maximum possible even (divisible by 2) sum. Please, calculate this value for Wet Shark.

Note, that if Wet Shark uses no integers from the n integers, the sum is an even integer 0.

Input

The first line of the input contains one integer, n (1 ≤ n ≤ 100 000). The next line contains n space separated integers given to Wet Shark. Each of these integers is in range from 1 to 109, inclusive.

Output

Print the maximum possible even sum that can be obtained if we use some of the given integers.

Sample Input

Input
3
1 2 3
Output
6
Input
5
999999999 999999999 999999999 999999999 999999999
Output
3999999996

Sample Output

Hint

In the first sample, we can simply take all three integers for a total sum of 6.

In the second sample Wet Shark should take any four out of five integers 999 999 999.

思路:

用sort先从小到大排序,把所有的数加起来,先判断总和是不是偶数,若是偶数直接输出,若不是则减去经排序后的最小的奇数,减去第一个奇数时要用for循环先找到第一个奇数的位置。

其次注意数据类型为long long或者__int64。

代码:

#include<stdio.h>
#include<algorithm>
using namespace std;
long long a[100005];
int main()
{
	int n;
	scanf("%d",&n);
	long long sum=0;
	for(int i=0;i<n;i++) 
	{
		scanf("%lld",&a[i]);
		sum+=a[i];
	} 
	sort(a,a+n);
	for(int i=0;i<n;i++)
	{
		if(sum%2==0)
		break;
		else
		{
			if(a[i]%2!=0)
			{
				sum-=a[i];
			} 
		}
	} 
	printf("%lld\n",sum);
	return 0;

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值