HDOJ 2141 Can you find it?

Can you find it?
Time Limit:3000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

Description

Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X. 
 

Input

There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers. 
 

Output

For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO". 
 

Sample Input

        
        
3 3 3 1 2 3 1 2 3 1 2 3 3 1 4 10
 

Sample Output

        
        
Case 1: NO YES NO
 
思路:把前两个数组加起来组成一个数组,并排序,然后对其下标进行二分,d[mid]与x-c[i]比较,只要存在一个就break;
代码:
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
long long a[510],b[510],c[510];
long long d[510*510];
int main()
{
	int L,M,N,s;
	int k=1;
	while(scanf("%d%d%d",&L,&N,&M)!=EOF)
	{
		for(int i=1;i<=L;i++)
		{
			scanf("%lld",&a[i]);
		}
		for(int i=1;i<=N;i++)
		{
			scanf("%lld", &b[i]);
		}
		for(int i=1;i<=M;i++)
		{
			scanf("%lld",&c[i]);
		}
		int t=0;
		for(int i=1;i<=L;i++)
		{
			for(int j=1;j<=N;j++)
			{
				d[++t]=a[i]+b[j];
			}
		}
		sort(d+1,d+t+1);
		scanf("%d",&s);
		printf("Case %d:\n",k++);
		while(s--)
		{	
		    bool flag=false;
			long long  x;
			scanf("%lld",&x);
			for(int i=1;i<=M;i++)
			{
			
				int l=1,r=t;//对下标二分,每次都找中间的那个下标,比较d[mid]与目标; 
				while(l<=r)
				{
					int mid=(l+r)/2;
					if(d[mid]==x-c[i])
					{
						flag=true;
						break;
					}
					else if(d[mid]<x-c[i])
					{
						l=mid+1;
					}
					else
					{
						r=mid-1;
					}
				}
				if(flag)//只要找到一个就可以终止; 
				   break;
			}
			if(flag)
			   printf("YES\n");
			else
			    printf("NO\n");
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值