HDU 1260 Tickets

Tickets
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible. 
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time. 
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help. 

Input

There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines: 
1) An integer K(1<=K<=2000) representing the total number of people; 
2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person; 
3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together. 

Output

For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm. 

Sample Input

2
2
20 25
40
1
8

Sample Output

08:00:40 am
08:00:08 am
 
      
用dp[ i ]表示前 i 个人买票需要的最短时间。one[ i ]表示第i个人单独买票需要的时间,two[ i ]表示第i-1和第i个人一起买票需要的时间。

状态转移方程为:
dp[0]=0;
dp[1]=a[1];
dp[i]=min(dp[i-1]+one[i],dp[i-2]+two[i]);  (i>=2)
代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int dp[2010];
int one[2010];
int tow[2010];
int main()
{
	int n,k;
	scanf("%d",&n);
	while(n--)
	{
		scanf("%d",&k);
		for(int i=1;i<=k;i++)
		{
			scanf("%d",&one[i]);
		}
		for(int i=2;i<=k;i++)
		{
			scanf("%d",&tow[i]);
		}
		dp[0]=0;
		dp[1]=one[1];
		for(int i=2;i<=k;i++)
		{
			dp[i]=min(dp[i-1]+one[i],dp[i-2]+tow[i]);
		}
		int h,m,s;
		m=dp[k]/60;
		s=dp[k]%60;
		h=8+m/60; 
		m=m%60;
		if(h>12)
		{
			printf("%02d:%02d:%02d pm\n",h,m,s);
		}
		else
		   printf("%02d:%02d:%02d am\n",h,m,s);
	} 
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值