I - Largest prime factor
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Description
Everybody knows any number can be combined by the prime number.
Now, your task is telling me what position of the largest prime factor.
The position of prime 2 is 1, prime 3 is 2, and prime 5 is 3, etc.
Specially, LPF(1) = 0.
Now, your task is telling me what position of the largest prime factor.
The position of prime 2 is 1, prime 3 is 2, and prime 5 is 3, etc.
Specially, LPF(1) = 0.
Input
Each line will contain one integer n(0 < n < 1000000).
Output
Output the LPF(n).
Sample Input
1 2 3 4 5
Sample Output
0 1 2 1 3
求n的最大素因数;
思路:用类似打表的方法打出每个数的最大素因数的位置,存入数组中;
代码:
#include<stdio.h>
#include<string.h>
int a[1000000+10];
int main()
{
int k=1;
memset(a,0,sizeof(a));
for(int i=2;i<=1000000;i++)
{
if(!a[i])
{
a[i]=k;
for(int j=i+i;j<=1000000;j+=i)
{
a[j]=k;//构造j的最大素因数的暂时位置;
}
k++;
}
}
int n;
while(scanf("%d",&n)!=EOF)
{
printf("%d\n",a[n]);
}
return 0;
}