HDU 2136 Largest prime factor

I - Largest prime factor
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Everybody knows any number can be combined by the prime number. 
Now, your task is telling me what position of the largest prime factor. 
The position of prime 2 is 1, prime 3 is 2, and prime 5 is 3, etc. 
Specially, LPF(1) = 0. 

Input

Each line will contain one integer n(0 < n < 1000000). 

Output

Output the LPF(n). 

Sample Input

1
2
3
4
5

Sample Output

0
1
2
1
3
求n的最大素因数;
思路:用类似打表的方法打出每个数的最大素因数的位置,存入数组中;
代码:
#include<stdio.h> 
#include<string.h>
int a[1000000+10];
int  main()
{
	int k=1;
	memset(a,0,sizeof(a));
	for(int i=2;i<=1000000;i++)
	{
		if(!a[i])
		{
			a[i]=k;
		    for(int j=i+i;j<=1000000;j+=i)
		    {
		    	a[j]=k;//构造j的最大素因数的暂时位置; 
		    }
		    k++;
		}
	}
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		printf("%d\n",a[n]);
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值