poj Period 1961

Period
Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 16988 Accepted: 8172

Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the 
number zero on it.

Output

For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

这几天一直在做最大流问题的题目,发现有点做不动,所以就一直没有更新博客。

也是这几个星期要考试的缘故没有太多的时间去学更多的东西, 以后一定补上。

这个题就是一个KMP的题目

题意就是让你找字符串的周期

如例2

前两个字母有两个周期,单周期为a

前六个字母也有两个周期,单周期为aab

前九个字母有三个周期,单周期为aab

....

代码:

#include <cstring>
#include <cstdio>
#include <algorithm>
#include <iostream>
using namespace std;

char ch[1000005];
int next[1000005];

void Get(char *s, int next[])
{
    int i, j;
    i = 0, j = -1;
    next[0] = -1;
    while ( s[i] )
    {
        if ( j == -1||s[i] == s[j] )
        {
            i++, j++;
            next[i] = j;
        }
        else
            j = next[j];
    }
}

int main()
{
    int n, i;
    int Num = 1;
    while ( ~scanf ( "%d", &n )&& n != 0 )
    {
        scanf ( "%s", ch );
        Get( ch, next );
        printf ( "Test case #%d\n", Num++ );
        for ( i = 1;i <= n; i++ )
        {
            if ( i%(i-next[i]) == 0&&i != i-next[i] )
                printf ( "%d %d\n", i, i/(i-next[i]) );
        }
        printf ( "\n" );
    }
    return 0;
}

代码菜鸟,如有错误,请多包涵!!!

如有帮助记得支持我一下,谢谢!!!

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值