poj1961 Period

Period
Time Limit: 3000MS   Memory Limit: 30000K
Total Submissions: 16368   Accepted: 7852

Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the 
number zero on it.

Output

For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

Source

Southeastern Europe 2004

Analysis

        这道题涉及了一个用next数组求最小循环节的技巧,这个在poj2406的题解里已经介绍过(超链接),这里不再赘述。
        这道题另一个需要想的地方就是判断是否是循环串,因为只要求考虑前缀,所以可以递推。令period[i]表示以第i个字符为结尾的前缀的循环周期(如果不是循环串,就设为1),那么对于前缀i,如果是循环字符串的话,一定有前缀next[i]也是循环串,且循环节为s[next[i]+1........i]。令l=i-next[i](即最小循环节长度),只要满足s[next[i]-l+1........next[i]]与s[i-l+1......i]相同且period[next[i]]=next[i]/l(是实除),那么s[1....i]就是以s[i-l+1.....i]为最小循环节的串。可以证明这样做的时间复杂度是O(n)的(自己想吧,实在累了,提示可以从每个位置被访问的次数来考虑)

Code

//poj1961 Period 字符串题
#include <cstdio>
#define maxlen 1000010
char s[maxlen];
int n, len, next[maxlen], period[maxlen];
bool test(int pos, int l)
{
	if((pos-l)%l!=0 || period[pos-l]!=(pos-l)/l)return false;
	for(int i=0;i<l;i++)
		if(s[pos-i]!=s[pos-l-i])return false;
	return true;
}
int main()
{
	int i, j, cnt=0;
	while(scanf("%d",&n),n)
	{
		scanf("%s",s+1);
		printf("Test case #%d\n",++cnt);
		period[1]=1;
		for(i=2,j=0;i<=n;i++)
		{
			period[i]=1;
			for(;s[j+1]!=s[i]&&j;j=next[j]);
			next[i]=s[j+1]==s[i]?++j:0;
			if(test(i,i-next[i]))period[i]=period[next[i]]+1;
			if(period[i]>1)printf("%d %d\n",i,period[i]);
		}
		printf("\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值