hdoj1319

题目:

Problem Description
A prime number is a counting number (1, 2, 3, …) that is evenly divisible only by 1 and itself. In this problem you are to write a program that will cut some number of prime numbers from the list of prime numbers between (and including) 1 and N. Your program will read in a number N; determine the list of prime numbers between 1 and N; and print the C*2 prime numbers from the center of the list if there are an even number of prime numbers or (C*2)-1 prime numbers from the center of the list if there are an odd number of prime numbers in the list.
Input
Each input set will be on a line by itself and will consist of 2 numbers. The first number (1 <= N <= 1000) is the maximum number in the complete list of prime numbers between 1 and N. The second number (1 <= C <= N) defines the C*2 prime numbers to be printed from the center of the list if the length of the list is even; or the (C*2)-1 numbers to be printed from the center of the list if the length of the list is odd.
Output
For each input set, you should print the number N beginning in column 1 followed by a space, then by the number C, then by a colon (:), and then by the center numbers from the list of prime numbers as defined above. If the size of the center list exceeds the limits of the list of prime numbers between 1 and N, the list of prime numbers between 1 and N (inclusive) should be printed. Each number from the center of the list should be preceded by exactly one blank. Each line of output should be followed by a blank line. Hence, your output should follow the exact format shown in the sample output.
Sample Input
21 2
18 2
18 18
100 7

Sample Output
21 2: 5 7 11

18 2: 3 5 7 11

18 18: 1 2 3 5 7 11 13 17

100 7: 13 17 19 23 29 31 37 41 43 47 53 59 61 67

题意是给你一个整数n和c,找出1~n范围内的素数(包括1).然后判断这个范围内有多少个素数,如果是奇数个则输出中间的c*2-1个素数,如果是偶数则输出中间的c*2个素数。

此题可能c*2-1或者c*2等于或超过n,此时需要输出这个区间的全部素数。

此题可以先将最大范围的素数用筛选法找到并打表,然后统计所求区间的个数,再输出中间的c*2-1或者c*2个素数。

参考代码:
#include <iostream>
#include <cstdio>
using namespace std;
const int N = 1000+10;
int n,c;
int prime[N];
int num[N];
void aishishaixuan() {
    for (int i = 0;i < N;++i) {
        num[i] = 1;
    }
    num[0] = 0;
    for (int i = 2;i < N / 2;++i) {
        for (int j = i * 2;j < N;j+=i) {
            num[j] = 0;
        }   
    }
    int j = 0;
    for (int i = 0;i < N;++i) {
        if (num[i]) {
            prime[j] = i;
            ++j;
        }
    }
}
int statistic() {
    int cnt = 0;
    for (int j = 0;prime[j] <= n;++j) {
        ++cnt;
    }
    return cnt;
}
bool isodd(int num) {
    if (num % 2) {
        return true;
    }
    return false;
}
int main() {
    aishishaixuan();
    while (scanf("%d%d", &n, &c) != EOF) {
        int cnt = statistic();
        if (cnt <= c * 2) {
            printf("%d %d:", n, c);         
            for (int i = 0;i < cnt;++i) {
                printf(" %d", prime[i]);
            }
            printf("\n");
        }
        else if (isodd(cnt)) {
            int er = (cnt - (c * 2 - 1)) / 2;
            printf("%d %d:", n,c);
            for (int i = er;i < er+(c*2-1);++i) {
                printf(" %d", prime[i]);
            }
            printf("\n");
        }
        else {
            int er = (cnt - (c * 2)) / 2;
            printf("%d %d:", n, c);
            for (int i = er;i < er+(c*2);++i) {
                printf(" %d", prime[i]);
            }
            printf("\n");
        }
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值