1001 A+B Format (20 point(s))

1001 A+B Format (20 point(s))

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −106≤a,b≤106. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991
#include<iostream>
#include<vector>

using namespace std;

int main(){
    
    int n,m=0;
    cin>>n>>m;
    int sum = n + m;
    if(sum == 0){
        cout<<0;
        return 0;
    }
    if(sum < 0){
        cout<< "-";
        sum *= -1;
    }
    vector<int> v;
    while(sum != 0){  // 要输出逗号,肯定要自己处理输出了
        v.push_back(sum%10);
        sum /= 10;
    }
    for(int i= v.size() - 1;i >= 0;i--){
        cout<< v[i];
        if(i>0&&i%3 == 0) cout<<',';  // i>0 才 ac 的,你能想得到???
        // 界限思维,非常重要啊。

    }
    
    
    return 0;
}
Sure! Here's the C++ code that calculates the first day on which Takahashi has to take K pills or less: ```cpp #include <iostream> #include <vector> int main() { int N, K; std::cin >> N >> K; std::vector<int> a(N); std::vector<int> b(N); for (int i = 0; i < N; i++) { std::cin >> a[i] >> b[i]; } long long day = 1; long long remainingPills = 0; for (int i = 0; i < N; i++) { remainingPills += a[i]; if (remainingPills >= K) { std::cout << day << std::endl; return 0; } day++; remainingPills -= b[i]; if (remainingPills <= 0) { remainingPills = 0; } } day += (remainingPills + K - 1) / K; std::cout << day << std::endl; return 0; } ``` In this code, we first take the inputs N and K, representing the number of medicine types and the maximum number of pills Takahashi can take in a day. Then we take the arrays `a` and `b`, where `a[i]` represents the number of days Takahashi has to take `b[i]` pills of the `i-th` medicine. We iterate through the arrays and keep track of the remaining pills. If at any point the remaining pills are greater than or equal to K, we output the current day and exit the program. Otherwise, we increment the day counter, reduce the remaining pills by `b[i]`, and if the remaining pills become less than or equal to 0, we set it to 0. Finally, if there are still remaining pills, we calculate the additional days needed by dividing the remaining pills by K (rounded up) and add it to the current day. The result is the first day on which Takahashi has to take K pills or less. Please note that this code assumes valid inputs and does not include any error handling.
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值