POJ 1163 The Triangle

The Triangle
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 45624 Accepted: 27615

Description

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right. 

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

Sample Output

30


题意:在给定的数字三角形中寻找一条从顶层到底层的路径,使此路径上的数字加和最大。

#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
int main()
{
	int r[105][105];
	int n;
	while(cin>>n)
	{
		for(int i=1;i<=n;i++)
		for(int j=0;j<i;j++)
		cin>>r[i][j];
		
		for(int i=n-1;i>=1;i--)
		{
			for(int j=0;j<i;j++)
			{
				r[i][j]+=max(r[i+1][j],r[i+1][j+1]);
			}
		}
		cout<<r[1][0]<<endl;
	}
	
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值