[PYTHON/JAVA](PAT)1005 SPELL IT RIGHT (20)

43 篇文章 0 订阅

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (<= 10^100^).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

 

12345

Sample Output:

 

one five

题目大意:

给定一个字符串,求字符串中的数字相加的和对应的英文字符。

分析:

获取字符串,将字符串中的每一位相加的值再转换成英文字符,输出

Java实现

import java.util.Scanner;



public class Main {

    public static void main(String[] args){

        Scanner sc = new Scanner(System.in);

        String digits[] = {"zero","one","two","three","four","five","six","seven","eight","nine"};

        String input = sc.next();

        sc.close();

        int sum = 0;

        for(int i=0;i<input.length();i++){

            sum += Integer.parseInt(String.valueOf(input.charAt(i)));

        }

        String temp = String.valueOf(sum);

        String output ="";

        for(int i=0;i<temp.length();i++){

            if(i==temp.length()-1){

                output += digits[Integer.parseInt(String.valueOf(temp.charAt(i)))];

            }else {

                output += digits[Integer.parseInt(String.valueOf(temp.charAt(i)))];

                output += " ";

            }

        }

        System.out.print(output);

    }

}

Python实现

if __name__ == "__main__":

    line = input()

    num = sum([int(x) for x in line])

    sums = str(num)

    digits = ["zero","one","two","three","four","five",

              "six","seven","eight","nine"]

    result = ''

    for x in sums:

        result = result + digits[int(x)] + ' '

    print(result[:-1])

更多技术干活,有趣文章,点这里就对了

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值