PAT A1037. Magic Coupon (25)

原文链接: PAT A1037. Magic Coupon (25)

上一篇: PAT A1033. To Fill or Not to Fill (25)

下一篇: PAT A1067. Sort with Swap(0,*) (25)

https://www.patest.cn/contests/pat-a-practise/1037

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

For example, given a set of coupons {1 2 4 -1}, and a set of product values {7 6 -2 -3} (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1<= NC, NP <= 105, and it is guaranteed that all the numbers will not exceed 230.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:

4
1 2 4 -1
4
7 6 -2 -3

Sample Output:

43

思路:

给出两个集合从这两个集合中分别选取相同数量的元素进行一对一相乘,问能得到的乘积之和最大是多少

对每一个集合将正数和负数分开考虑(0不影响),然后对每个集合从小到大排序,这样绝对值最大的负数在数组的最左端,绝对值最大的正数在数组的最右端,然后从左往右进行负数乘积的累加,从右往左进行正数的乘积的累加

注意

1,正负数个数不相同以及0的考虑

2,在进行排序后取两个集合的最大正数时应分别取位置n-1和m-1,而不是他们的最小值min(n-1,m-1)

3,进行累加的循环中,不能以coupon[i]*product[i]>0(处理负数)或者coupon[i]*product[i]>0(处理正数)作为判断条件,因为会在两个集合正数个数相等,负数个数相等时发生错误

4,数据类型int即可,为了保险起见,long long也行

#include <iostream>
#include <cstdio>
#include <algorithm>

using namespace std;

const int MAX = 100010;
int coupon[MAX], product[MAX];
int main(int argc, char *argv[]) {
	int n, m;
	scanf("%d", &n);
	for (int i = 0; i < n; i++)
		scanf("%d", coupon + i);
	scanf("%d", &m);
	for (int i = 0; i < m; i++)
		scanf("%d", product + i);

	//从小到大排序 
	sort(coupon, coupon + n);
	sort(product, product + m);
	int i = 0, j, ans = 0;
	while (i < n && i < m && coupon[i] < 0 && product[i] < 0) {
		ans += coupon[i] * product[i];
		i++;
	}
	i = n - 1;
	j = m - 1;
	while (i >= 0 && j >= 0 && coupon[i] > 0 && product[j] > 0) {
		ans += coupon[i] * product[j];
		i--, j--;
	}
	printf("%d\n", ans);

	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值