【PAT】1037. Magic Coupon (25)

题目描述

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product… but hey, magically, they have some coupons with negative N’s!

For example, given a set of coupons {1 2 4 -1}, and a set of product values {7 6 -2 -3} (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M $7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

翻译:火星上的魔法商店提供了一些不可思议的优惠券。每张优惠券上面有一个正整数N,这意味着当你对一个商品使用此优惠券,你可能获得N倍这个商品的价值!还有,这个商店也提供一些免费的商品。但是,如果你用一个正整数N的优惠券去买这个商品,你需要给商店N倍这个商品的价值。。。但是,神奇的是,他们有些优惠券是负整数N!

INPUT FORMAT

Each input file contains one test case. For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1<= NC, NP <= 105, and it is guaranteed that all the numbers will not exceed 230.

翻译:每个输入文件包含一组测试数据。对于每组输入数据,第一行包括优惠券数NC,跟着一行包括N个正整数代表每张优惠券的值。接着一行为商品数NP,接着为NP个数代表每个商品的价值。1<= NC, NP <= 10^5,数据保证所有数字都不会超过2^30。

OUTPUT FORMAT

For each test case, simply print in a line the maximum amount of money you can get back.

翻译:对于每组输入数据,输出一行你可以获得的金钱的最大值。


Sample Input:

4
1 2 4 -1
4
7 6 -2 -3

Sample Output:

43


解题思路

这道题难点是在读题吧。。。其实就是排序后从两边取数相乘,遇到符号不同就停止。我选择用优先队列分别保存两个数列中的正数和负数,将它们相乘后相加即为答案。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<queue>
#include<algorithm>
#define INF 99999999
using namespace std;
priority_queue<int> pos[2];
priority_queue<int> neg[2];
int N;
int main(){
    for(int i=0;i<2;i++){
        scanf("%d",&N);
        int a;
        for(int j=0;j<N;j++){
            scanf("%d",&a);
            if(a>0)pos[i].push(a);
            if(a<0)neg[i].push(-a);
        }
    }
    int l1=min(pos[0].size(),pos[1].size());
    int l2=min(neg[0].size(),neg[1].size());
    int sum=0;
    for(int i=0;i<l1;i++){
        int t1=pos[0].top();pos[0].pop();
        int t2=pos[1].top();pos[1].pop();
        sum+=t1*t2;
    }
    for(int i=0;i<l2;i++){
        int t1=neg[0].top();neg[0].pop();
        int t2=neg[1].top();neg[1].pop();
        sum+=t1*t2;
    }   
    printf("%d\n",sum);
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值